[Bioc-devel] Unable to use lldb debugger

Hani Habra hh@br@1 @end|ng |rom gm@||@com
Thu Jul 1 19:47:29 CEST 2021

Hi All,
I'm trying to use the lldb debugger to debug some R code, but keep getting
the following error:

(base) R -d lldb
(lldb) target create "/Library/Frameworks/R.framework/Resources/bin/exec/R"
Current executable set to
'/Library/Frameworks/R.framework/Resources/bin/exec/R' (arm64).
(lldb) run
error: process exited with status -1 (attach failed (Not allowed to attach
to process.  Look in the console messages (Console.app), near the
debugserver entries when the attached failed.  The subsystem that denied
the attach permission will likely have logged an informative message about
why it was denied.))

I tried looking at Console.app, but couldn't find anything informative
there. Only thing I found was "enabling developer mode" with "sudo
DevToolsSecurity -enable", but that solved nothing. Does anyone understand
what the issue is?

Hani Habra

	[[alternative HTML version deleted]]

More information about the Bioc-devel mailing list