[Bioc-devel] Unable to use lldb debugger

Shian Su @u@@ @end|ng |rom weh|@edu@@u
Fri Jul 2 07:18:50 CEST 2021

Hi Hani,

The command you showed works fine on my MacBook Pro. However I am on an Intel Mac. I see that your R is (arm64), so there’s probably some issues trying to attach across compatibility layers.

Does your debugging specifically require C level debugging, and also M1 Macs? I’d see how far you can get with the R debugger and consider using another machine to do lldb level debugging.

Kind regards,

> On 2 Jul 2021, at 3:47 am, Hani Habra <hhabra1 using gmail.com> wrote:
> Hi All,
> I'm trying to use the lldb debugger to debug some R code, but keep getting
> the following error:
> (base) R -d lldb
> (lldb) target create "/Library/Frameworks/R.framework/Resources/bin/exec/R"
> Current executable set to
> '/Library/Frameworks/R.framework/Resources/bin/exec/R' (arm64).
> (lldb) run
> error: process exited with status -1 (attach failed (Not allowed to attach
> to process.  Look in the console messages (Console.app), near the
> debugserver entries when the attached failed.  The subsystem that denied
> the attach permission will likely have logged an informative message about
> why it was denied.))
> I tried looking at Console.app, but couldn't find anything informative
> there. Only thing I found was "enabling developer mode" with "sudo
> DevToolsSecurity -enable", but that solved nothing. Does anyone understand
> what the issue is?
> Thanks,
> Hani Habra
> 	[[alternative HTML version deleted]]
> _______________________________________________
> Bioc-devel using r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/bioc-devel

More information about the Bioc-devel mailing list