[Bioc-devel] Question reg devtools in MacOS High Sierra

Nitesh Turaga ntur@g@@b|oc @end|ng |rom gm@||@com
Thu Feb 11 18:03:17 CET 2021


Could you provide more information about the error you face with `brew install libgit2` ?? Without knowing what error message you see, it's hard to speculate about why devtools or gert didn’t work.


On 2/11/21, 12:00 AM, "Bioc-devel on behalf of Krithika Bhuvaneshwar" <bioc-devel-bounces using r-project.org on behalf of kb472 using georgetown.edu> wrote:


    We are the package maintainers of the CINdex package. Our package is giving
    build errors and we are investigating why. I'm currently working on setting
    up the environment so I can replicate the error.

    I have a MacOS High Sierra. Here is what I did:
    * downloaded R 4.1 from  https://mac.r-project.org/ and
    * Got the latest  BioC 3.13 using BiocManager::install(version = "devel")

    * When I tried *install.packages("devtools")*, it said
    *"Package which is only available in source form, and may need compilation
    of **C/C++/Fortran: ‘gert’*

    So Then I did *install.packages("devtools")*

    It gave me an error saying
    *"Configuration failed to find libgit2 library." Try installing: brew:
    libgit2 (MacOS)*
    I have tried installing libgit2 using both brew and within R. Neither
    worked. So at this point, I'm unable to install devtools . And without
    devtools, Check And Build are not working

    Has anyone else encountered this issue, please advise on how to fix this.


    	[[alternative HTML version deleted]]

    Bioc-devel using r-project.org mailing list

More information about the Bioc-devel mailing list