[Bioc-devel] Question reg devtools in MacOS High Sierra

Krithika Bhuvaneshwar kb472 @end|ng |rom georgetown@edu
Thu Feb 11 05:59:56 CET 2021


We are the package maintainers of the CINdex package. Our package is giving
build errors and we are investigating why. I'm currently working on setting
up the environment so I can replicate the error.

I have a MacOS High Sierra. Here is what I did:
* downloaded R 4.1 from  https://mac.r-project.org/ and
* Got the latest  BioC 3.13 using BiocManager::install(version = "devel")

* When I tried *install.packages("devtools")*, it said
*"Package which is only available in source form, and may need compilation
of **C/C++/Fortran: ‘gert’*

So Then I did *install.packages("devtools")*

It gave me an error saying
*"Configuration failed to find libgit2 library." Try installing: brew:
libgit2 (MacOS)*
I have tried installing libgit2 using both brew and within R. Neither
worked. So at this point, I'm unable to install devtools . And without
devtools, Check And Build are not working

Has anyone else encountered this issue, please advise on how to fix this.


	[[alternative HTML version deleted]]

More information about the Bioc-devel mailing list