[Bioc-devel] Error when building BgeeCall package on Mac OS

Martin Morgan mtmorg@n@b|oc @end|ng |rom gm@||@com
Tue Apr 2 15:21:35 CEST 2019

I added a response to your issue at


encouraging you (again) to avoid installing software on the user system; there are basic problems with this approach, and the correct solution is to list kallisto as a SystemDependency: in your DESCRIPTION file.


On 4/2/19, 4:17 AM, "Bioc-devel on behalf of Julien Wollbrett" <bioc-devel-bounces using r-project.org on behalf of julien.wollbrett using sib.swiss> wrote:

    My package (called BgeeCall) is under review and passed R CMD Build and 
    R CMD Check for Linux and windows.
    I still have an error on Mac. I tried to reproduce it using different 
    versions of R (3.5 and 3.6) and different OS
    versions (Sierra and El Capitan). I tried on 5 different computers but 
    still not able to reproduce this error.
    Does anyone have any idea on the origin of this error ? What should I 
    try to do to solve it?
    dyld: Library not loaded: @rpath/libz.1.dylib
       Referenced from: /private/var/folders/gh/37kcv9bj20v2qnpgxq14hh1c0000gq/T/Rtmp7eA44u/Rbuild1406e51fd6e7f/BgeeCall/kallisto/kallisto
       Reason: image not found
    Will run kallisto using this command line : /private/var/folders/gh/37kcv9bj20v2qnpgxq14hh1c0000gq/T/Rtmp7eA44u/Rbuild1406e51fd6e7f/BgeeCall/kallisto/kallisto quant -i /private/var/folders/gh/37kcv9bj20v2qnpgxq14hh1c0000gq/T/Rtmp7eA44u/Rbuild1406e51fd6e7f/BgeeCall/intergenic_0.1/6239/kallisto/transcriptome_WBcel235/transcriptome.idx -o /private/var/folders/gh/37kcv9bj20v2qnpgxq14hh1c0000gq/T/Rtmp7eA44u/Rbuild1406e51fd6e7f/BgeeCall/intergenic_0.1/6239/kallisto/transcriptome_WBcel235/annotation_WBcel235_84/SRX099901_subset -t 1 --single -l 180 -s 30 --bias  /private/var/folders/gh/37kcv9bj20v2qnpgxq14hh1c0000gq/T/Rtmp7eA44u/Rinst1406e55617de6/BgeeCall/extdata/SRX099901_subset/SRR350955_subset.fastq.gz
    dyld: Library not loaded: @rpath/libz.1.dylib
       Referenced from: /private/var/folders/gh/37kcv9bj20v2qnpgxq14hh1c0000gq/T/Rtmp7eA44u/Rbuild1406e51fd6e7f/BgeeCall/kallisto/kallisto
       Reason: image not found
    You can access to the submission issue here :
    Thank you for your answers.
    Julien Wollbrett
    	[[alternative HTML version deleted]]
    Bioc-devel using r-project.org mailing list

More information about the Bioc-devel mailing list