[Bioc-devel] choosing R version dependency for existing packages

Martin Morgan mtmorg@n@bioc @ending from gm@il@com
Sat Nov 3 09:37:35 CET 2018

If users are 'playing by the books' and using BiocManager::install(), the version of R is coupled with the version of Bioconductor / your package, so specifying an R version is irrelevant. In addition, saying your package has a dependency R >=... implies that there will be no breaking changes in some future R, which requires a certain amount of foresight. And using R itself would seem to be a requirement for an R package. So in principle my feeling is that it doesn't make sense to include R or an R version as a dependency.

In a more practical setting it might be that your package depends on a specific feature of R, or that you yourself are only confident that a particular version of R will provide the needs of your package. It might then be appropriate to specify that R version. Again in the domain of the ideal, new R features would be introduced in R-devel, with bug fixes only in the point releases. So a dependency like R >= 3.5.0 would seem appropriate.

I'm not sure whether these comments are helpful or not... __


On 11/2/18, 3:19 PM, "Bioc-devel on behalf of Paul Shannon" <bioc-devel-bounces using r-project.org on behalf of paul.thurmond.shannon using gmail.com> wrote:

    A user of MotifDb requests - sensibly, I think - that I loosen the requirement
      Depends: R (>= 3.5.1)
    which I added before the release.   This seems sensible and supported by, for example, R (>= 2.10) in GenomicRanges.
    Is this, then, the heuristic?
      - new packages should depend on the lastest release of R
      - older existing packages should depend on earlier
        versions of R, possibly sticking with the version of R in 
        which they originally appeared, as long as they have not 
        been subsequently modified to use new R features.
    - Paul
    Bioc-devel using r-project.org mailing list

More information about the Bioc-devel mailing list