[Bioc-devel] Git error when pushing to bioconductor

Shepherd, Lori Lori@Shepherd @ending from Ro@wellP@rk@org
Mon Jun 4 03:28:47 CEST 2018

Have you tried doing a 'git pull upstream master' ?  Do you get any messages when running that command?

Generally try the following and post any error messages:
Git pull upstream master
( resolve any merge conflicts and commit )
( make any additional changes and commit)
Git push upstream master

Lori Shepherd
Bioconductor Core Team
Roswell Park Cancer Institute
Department of Biostatistics & Bioinformatics
Elm & Carlton Streets
Buffalo, New York 14263
From: Bioc-devel <bioc-devel-bounces using r-project.org> on behalf of Kangeyan, Divy <divyswar01 using g.harvard.edu>
Sent: Sunday, June 3, 2018 4:07:48 PM
To: Bioc-devel using r-project.org
Subject: [Bioc-devel] Git error when pushing to bioconductor

    I maintain the scmeth package in bioconductor. Recently I made some
changes to the packages in my local branch and when I tried pushing it to
the bioconductor I got an error saying (Updates were rejected because the
tip of your current branch is behind its remote counterpart). I have
attached the screenshot.

I tried resolving the conflict manually and after that when I pushed the
changes I still got the same error. Any help with resolving the error is
greatly appreciated.

Thank you,
Divy Kangeyan

This email message may contain legally privileged and/or confidential information.  If you are not the intended recipient(s), or the employee or agent responsible for the delivery of this message to the intended recipient(s), you are hereby notified that any disclosure, copying, distribution, or use of this email message is prohibited.  If you have received this message in error, please notify the sender immediately by e-mail and delete this email message from your computer. Thank you.
	[[alternative HTML version deleted]]

More information about the Bioc-devel mailing list