[Bioc-devel] git svn permissions

Thomas Lawson thomas.nigel.lawson at gmail.com
Tue Oct 3 17:04:09 CEST 2017

Hi all,

I have been trying to link my existing github repository to my bioconductor
repository but I am having a bit of trouble...

I have been following: https://master.bioconductor

I have the an existing github repository (github.com/viant-metabolomics/
msPurity) that I would like to use maintain my bioconductor repository

I have created a SSH key with github and used the git /svn form

   - Using my old svn account username (t.lawson) for the "enter your SVN
   user id" section

   - Using a my github username (tomnl) for the "SSH public key or your
   GitHub id" section

I can then run the following command OK "git remote add upstream git at git.

And when I run "git remote -v" I get:

# origin    https://github.com/Viant-Metabolomics/msPurity (fetch)
# origin    https://github.com/Viant-Metabolomics/msPurity (push)
# upstream    git at git.bioconductor.org:packages/msPurity.git (fetch)
# upstream    git at git.bioconductor.org:packages/msPurity.git (push)

But when I run "git fetch --all" I get a prompt for a password for thomas.
nigel.lawson at gmail.com

I tried the password that I set for the SSH key but I couldn't get access.

In case I made a mistake somewhere, I have just repeated the process. I
have just created a new SSH key following https://help.github

The resubmitted the new SSH public key with Github and resubmitted the git/
svn form (03/10/2017  approx 14:00).

I now get another error when I run 'git fetch upstram':

# Permission denied (publickey).
# fatal: Could not read from remote repository.

# Please make sure you have the correct access rights and the repository

Apologies if I have missed something straightforward

Kind regards,


	[[alternative HTML version deleted]]

More information about the Bioc-devel mailing list