[Bioc-devel] Updating package

Charles Determan cdetermanjr at gmail.com
Thu Jan 5 19:25:44 CET 2017

I committed my changes earlier this morning from the 'devel' branch via the
'git svn dcommit --add-author-from' the website (
https://www.bioconductor.org/developers/how-to/git-mirrors/).  I have yet
to see any changes on the build page though for the `devel` (
http://master.bioconductor.org/checkResults/3.5/bioc-LATEST/).  Did I miss
another step or is the build process reporting slow or perhaps I am looking
in the wrong place still?


On Thu, Jan 5, 2017 at 9:47 AM, Charles Determan <cdetermanjr at gmail.com>

> That seems to have been the issue.  It had been some time since I needed
> to commit to bioconductor I forgot my username was different.  Thank you
> Martin for pointing that simple problem out.  I have now 'dcommit' my
> 'devel' branch so if I understand correctly the changes should be with
> bioconductor to apply accordingly.
> Regards,
> Charles
> On Thu, Jan 5, 2017 at 9:22 AM, Martin Morgan <
> martin.morgan at roswellpark.org> wrote:
>> On 01/05/2017 10:18 AM, Charles Determan wrote:
>>> Not to be pushy but did anyone have any insights with this?  I would hate
>>> to have my package still sitting with the bug fix it requires.
>> maybe svn credentials,
>>  git svn rebase --username=c.determan
>> ??
>>> Thanks,
>>> Charles
>>> On Wed, Jan 4, 2017 at 11:15 AM, Charles Determan <cdetermanjr at gmail.com
>>> >
>>> wrote:
>>> Hi,
>>>> I received a notification that my package was failing some tests.  I
>>>> have
>>>> since made the necessary fixes and pushed my changes to the github repo.
>>>> Previously this would result in http://gitsvn.bioconductor.
>>>> org/git-push-hook updating the package for bioconductor.  I noticed
>>>> however that this delivery fails and that the git-svn bridge is no
>>>> longer
>>>> available.
>>>> How should I modify my current repository to update my package
>>>> accordingly?
>>>> I have my local changes in the 'devel' branch.
>>>> I ran the update_ remotes.sh
>>>> I run 'git svn rebase' but I get the following error:
>>>> Can't create session: Unable to connect to a repository at URL '
>>>> https://hedgehog.fhcrc.org/bioconductor/trunk/madman/Rpacks/OmicsMarkeR
>>>> ':
>>>> Unexpected server error 500 'Internal Server Error' on
>>>> '/bioconductor/trunk/madman/Rpacks/OmicsMarkeR' at
>>>> /mingw64/share/perl5/site_perl/Git/SVN.pm line 717.
>>>> What did I miss here?
>>>> Thanks,
>>>> Charles
>>>         [[alternative HTML version deleted]]
>>> _______________________________________________
>>> Bioc-devel at r-project.org mailing list
>>> https://stat.ethz.ch/mailman/listinfo/bioc-devel
>> This email message may contain legally privileged and/or confidential
>> information.  If you are not the intended recipient(s), or the employee or
>> agent responsible for the delivery of this message to the intended
>> recipient(s), you are hereby notified that any disclosure, copying,
>> distribution, or use of this email message is prohibited.  If you have
>> received this message in error, please notify the sender immediately by
>> e-mail and delete this email message from your computer. Thank you.

	[[alternative HTML version deleted]]

More information about the Bioc-devel mailing list