[Bioc-devel] Updating bioconductor after computer transfer - problem

Christopher John chris.r.john86 at gmail.com
Fri Dec 15 08:06:27 CET 2017


I have recently copy and pasted my github directory from my old PC to a new
PC. I can update the github still fine, but bioconductor I get an error:

christopher at RA-MAP:~/M3C$ git remote -v
origin    https://github.com/crj32/M3C (fetch)
origin    https://github.com/crj32/M3C (push)
upstream    git at git.bioconductor.org:packages/M3C.git (fetch)
upstream    git at git.bioconductor.org:packages/M3C.git (push)

...... the usual commands

christopher at RA-MAP:~/M3C$ git push origin master
Username for 'https://github.com': crj32
Password for 'https://crj32@github.com':
Everything up-to-date

christopher at RA-MAP:~/M3C$ git push upstream master
Permission denied (publickey).
fatal: Could not read from remote repository.
Please make sure you have the correct access rights
and the repository exists.

I guessed this was to do with the ssh key not being update to date with the
one from the new PC. So I followed the directions on this site and got my
local ssh key, added it to the github, then sent the ssh key off to the
bioconductor through the google forms page. Still no luck, same error. Was
this the correct thing to do?




	[[alternative HTML version deleted]]

More information about the Bioc-devel mailing list