[Bioc-devel] Dependency issue

t.kuilman at nki.nl t.kuilman at nki.nl
Sat Apr 18 08:30:14 CEST 2015

Hello everyone,

I have tested whether our new package CopywriteR could be installed, but surprisingly got the message that it could not be installed under R 3.1.2:

Warning message:
package ‘CopywriteR’ is not available (for R version 3.1.2)

All the dependencies of CopywriteR have R >= 3.1.0 or these depend on earlier versions of R. Can anyone tell me whether this dependency is imposed by Bioconductor or what would be the explanation for this? (I did note that during the BiocCheck checks I got the recommendation to update the R version dependency to 3.2 but I would rather have it backward compatible with older versions of R too)



R version 3.1.2 (2014-10-31)
Platform: x86_64-pc-linux-gnu (64-bit)

 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C
 [3] LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8
 [7] LC_PAPER=en_US.UTF-8       LC_NAME=C
 [9] LC_ADDRESS=C               LC_TELEPHONE=C

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base

other attached packages:
[1] BiocInstaller_1.16.2

loaded via a namespace (and not attached):
[1] tools_3.1.2

Thomas Kuilman, PhD
Department of Molecular Oncology
Netherlands Cancer Institute
1066 CX Amsterdam
The Netherlands

Phone: +31-20-5121841

More information about the Bioc-devel mailing list