[Bioc-devel] assayDat and ExpressionSet

Gordon Smyth smyth at wehi.EDU.AU
Mon Oct 22 06:11:32 CEST 2007

>Date: Thu, 18 Oct 2007 16:49:26 -0400 (EDT)
>From: Vincent Carey 525-2265 <stvjc at channing.harvard.edu>
>Subject: Re: [Bioc-devel] assayDat and ExpressionSet
>To: Wolfgang Huber <huber at ebi.ac.uk>
>Cc: bioC-devel <bioc-devel at stat.math.ethz.ch>
> > Vincent Carey 525-2265 wrote:
> > > i think the phenoData class should be defunct at next release,
> > > but the slots should retain their names.
> >
> > I think "featureData" and "sampleData" would be more consistent as the
> > prefered accessor functions to the annotatedDataframes for annotating
> > 'rows' and 'colums' of an eSet, respectively.
> >
> > I don't care too much how the slot in the class implementation is
> > called, but if our software is what we claim it is, we might as well
> > also be able to rename the eSet slot "phenoData" to "sampleData", and
> > keep accessor functions named phenoData and phenoData<- (that do the
> > same as sampleData...) still around for a couple of releases.
> >
> > This is a long-term question of low urgency, but I do find it important
> > for the user experience that we call things by their proper names and
> > not use inexact and potentially confusing terminology (or doesn't it
> > make you whince when your biological collaborators talk of "p-values"
> > when they mean regression coefficients?)
>"phenoData" has reasonable associations among the users/students 
>i've encountered.
>so the need for an alternate name for the accessor is not completely
>clear.  but i would have no strong objection to these changes once
>resources to carry them out were identified.

I strongly agree with Wolfgang on this. The term "phenoData" is 
actively confusing for local users in my neck of the woods. In most 
of the microarray data I deal with, the covariates associated with 
the RNA target samples are either genotypes or treatments, so the 
term "pheno" is the opposite of correct. Either "sample" or "target" 
would be right. As Wolfgang says, it's just a matter of calling 
something what it is.

Best wishes

More information about the Bioc-devel mailing list