[R-sig-ME] Erratic cross-platform behavior of glmmADMB

Gionata Bocci boccigionata at gmail.com
Tue Oct 11 13:59:13 CEST 2016

Dear list members,

I am writing because I've come across a puzzling situation when working
with glmmADMB::glmmmadmb.
I have a glmmmadmb(..., family = "nbinom") model which runs smoothly on a
Windows machine, while, on my Ubuntu 16.04 returns the following messages
(sorry for the rather long output):


  "matrix not pos definite in sparse choleski
   !!!! trace_log: zero diagonal element
  [...many other trace_log warnings...]

   matrix not pos definite in sparse choleski
   Error: Invalid index 157882075 used for array range [0, 107] in "double&
dvector::operator[] (int i)".
    array bound exceeded -- index too high

   Parameters were estimated, but standard errors were not: the most likely
problem is that the curvature at MLE was zero or negative
   Error in glmmadmb(perc_fill ~ treatment * variety + year + (1 |
ls.def/d_new),  :
   The function maximizer failed (couldn't find parameter file)
Troubleshooting steps include (1) run with 'save.dir' set and inspect
output files; (2) change run parameters: see '?admbControl';(3) re-run with
debug=TRUE for more information on failure mode
   In addition: Warning message:  running command './glmmadmb -maxfn 500
-maxph 5 -noinit -shess' had status 42 "


  I've tried the suggested troubleshootings but I got the same results.
  On both machines I am using the github version of the package and the
latest R release (3.3.1).
  I've also tried to use the package version found at "
http://glmmadmb.r-forge.r-project.org/repos" (as suggested at the glmmADMB
website) but with no luck (I also wanted to try the "Buildbot" version, but
it looks like the link is broken).

  Looking at the source code, I've noticed the following points:

   * the buildbot page is down, thus the glmmADMB:::get_bbot_versions()
function does not work (but this shouldn't be an issue in my case)
   * it looks like that the only platform-specific commands are those
related to "founding the binary of glmmadmb", "create a tmp
directory"...nothing which should affect the output of the function.

  Has anybody faced a similar situation? Do you have any tentative
explanation (and possible fixes) for this "erratic" behavior?



	[[alternative HTML version deleted]]

More information about the R-sig-mixed-models mailing list