[R-sig-ME] possible lmer compatibility bug?

Douglas Bates bates at stat.wisc.edu
Wed Aug 20 19:19:29 CEST 2008

On Wed, Aug 20, 2008 at 12:02 PM, Brandon Invergo
<brandon at brandoninvergo.com> wrote:
> Dear all,

> I was just driving myself crazy trying to figure out this sudden error
> message I was getting on lines of code that were working fine the other day.
> Every time I tried to make a model with the lmer() function, it would return
> the following error: "Error in asMethod(object) : matrix is not symmetric
> [1,2]"

> I realized, though, that the only thing that had changed was the version of
> R I was using, having just switched to version 2.7.1. Sure enough, when I
> loaded up v2.7.0, the script worked fine and I could successfully call lmer.

> Is there something I'm possibly doing wrong that's preventing it from
> working in 2.7.1? Or is this a known problem?

It appears that you have too high a regard for the readers of this
list in that you expect them to have psychic powers :-)

More seriously, if you read your message and think of how a person
could possibly create a meaningful response based on the information
that you have given us, I think you will see that we don't have nearly
enough information to go on.

A reproducible example rather than a description of "lines of code
that were working fine" is what we will need before we can expect to
provide a useful answer to you.  Also, information like the output


and perhaps


after the error message so we know what was going on at the time the
error occurred.  Most importantly, we need to know what the call was
that resulted in an error.

More information about the R-sig-mixed-models mailing list