[R-meta] stepadj argument ignored in an rma.mv model

Viechtbauer, Wolfgang (SP) wo||g@ng@v|echtb@uer @end|ng |rom m@@@tr|chtun|ver@|ty@n|
Tue May 7 08:07:35 CEST 2019

Dear Danka,

rma.uni() and rma.mv() use different optimization routines. The link you sent mostly pertains to rma.uni(). For one thing, the optimizers used in rma.mv() do not have a 'stepadj' control argument (which is also what the warning message is telling you).

If you run into convergence problems with rma.mv(), first take a look at help(rma.mv) and the "Note" section towards the end. One of the first things you can try is to switch to 'optim' for the optimizer and then use either the 'BFGS' or 'Nelder-Mead' methods. So:

control=list(optimizer="optim", optmethod="BFGS") 


control=list(optimizer="optim", optmethod="Nelder-Mead")

Maybe that already fixes things. If so, please also run profile() on the fitted model to make sure that all variance components are clearly identiable. See help(profile.rma.mv).


-----Original Message-----
From: R-sig-meta-analysis [mailto:r-sig-meta-analysis-bounces using r-project.org] On Behalf Of Danka Puric
Sent: Monday, 06 May, 2019 12:28
To: r-sig-meta-analysis using r-project.org
Subject: [R-meta] stepadj argument ignored in an rma.mv model

Hi everyone!

I'm running a meta-analysis using the rma.mv function and have run into
some issues with the stepadj argument.

One of the models I'm testing won't converge, with the following message:
Error in rma.mv(ES_corrected, SV, random = list(~1 | MA_data$IDeffect,  :
  Optimizer (nlminb) did not achieve convergence (convergence = 1).

Following the advice on this page:
I tried increasing the number of iterations (up to maxiter = 10000), but
the model wouldn't converge. I then tried shortening the step length to
stepadj = 0.5. The model still failed to converge, but I also got the
following message:
Warning message:
In nlminb(start = c(con$sigma2.init, con$tau2.init, con$rho.init,  :
  unrecognized control elements named ‘stepadj’ ignored

I get the same message when I try to adjust step length for models that do
converge, so I'm hopeful that this model would also converge if only I
could get the stepadj to work.

Has anyone else had this issue when using stepadj with the rma.mv function?
Any input would be greatly appreciated. Thank you in advance!


More information about the R-sig-meta-analysis mailing list