[R-meta] stepadj argument ignored in an rma.mv model

Danka Puric dj@gu@rd @end|ng |rom gm@||@com
Mon May 6 12:27:53 CEST 2019

Hi everyone!

I'm running a meta-analysis using the rma.mv function and have run into
some issues with the stepadj argument.

One of the models I'm testing won't converge, with the following message:
Error in rma.mv(ES_corrected, SV, random = list(~1 | MA_data$IDeffect,  :
  Optimizer (nlminb) did not achieve convergence (convergence = 1).

Following the advice on this page:
I tried increasing the number of iterations (up to maxiter = 10000), but
the model wouldn't converge. I then tried shortening the step length to
stepadj = 0.5. The model still failed to converge, but I also got the
following message:
Warning message:
In nlminb(start = c(con$sigma2.init, con$tau2.init, con$rho.init,  :
  unrecognized control elements named ‘stepadj’ ignored

I get the same message when I try to adjust step length for models that do
converge, so I'm hopeful that this model would also converge if only I
could get the stepadj to work.

Has anyone else had this issue when using stepadj with the rma.mv function?
Any input would be greatly appreciated. Thank you in advance!


	[[alternative HTML version deleted]]

More information about the R-sig-meta-analysis mailing list