[R-SIG-Mac] Using cairo on arm64 macOS

Jean Thioulouse je@n@th|ou|ou@e @end|ng |rom un|v-|yon1@|r
Wed Mar 16 16:18:26 CET 2022


No problem with cairo here. I have a MacBook M1 with plain R install and I can use svg, cairo_pdf and cairo_ps.
Maybe try to re-install R...

> capabilities()
       jpeg         png        tiff       tcltk         X11        aqua 
       TRUE        TRUE        TRUE        TRUE        TRUE        TRUE 
   http/ftp     sockets      libxml        fifo      cledit       iconv 
       TRUE        TRUE        TRUE        TRUE        TRUE        TRUE 
        NLS       Rprof     profmem       cairo         ICU long.double 
       TRUE        TRUE        TRUE        TRUE        TRUE       FALSE 
> sessionInfo()
R version 4.1.2 (2021-11-01)
Platform: aarch64-apple-darwin20 (64-bit)
Running under: macOS Monterey 12.2.1

Matrix products: default
BLAS:   /Library/Frameworks/R.framework/Versions/4.1-arm64/Resources/lib/libRblas.0.dylib
LAPACK: /Library/Frameworks/R.framework/Versions/4.1-arm64/Resources/lib/libRlapack.dylib

Random number generation:
 RNG:     Mersenne-Twister 
 Normal:  Inversion 
 Sample:  Rounding 
[1] fr_FR.UTF-8/fr_FR.UTF-8/fr_FR.UTF-8/C/fr_FR.UTF-8/fr_FR.UTF-8

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
[1] compiler_4.1.2 tools_4.1.2   

> Le 16 mars 2022 à 14:41, Jan Netík <netikja using gmail.com> a écrit :
> Hi,
> This is a repost of a topic which I have accidentally posted on r-devel mailing list:
> first, let me appreciate the efforts around "Apple Silicone" builds of R, works like a charm! However, I have found recently that this build does not have cairo in capabilities() and in turn I cannot use cairo_pdf device. Intel build has cairo readily available, but M1 does not. I have done various attempts on installing cairo using brew or install.package("Cairo"); maybe the most preferable way is to follow https://mac.r-project.org/bin/, but that also failed stating "architecture aarch64 is not supported on os darwin20, only available architectures: x86_64arm64". I have also tried downloading cairo from https://mac.r-project.org/bin/darwin20/arm64/ and copying it into opt/R/arm64, but with no success... Nor current devel R worked for me in that issue.
> I think that I overlooked something, maybe around installing cairo to opts/R/arm64 (is it really mere copying?). In that case I would edit the docs and websites around the Apple Silicone build to better clarify what needs to be done, but I may be that cairo is just not yet supported.
> Anyway many thank for looking into this!
> Best,
> Jan
> _______________________________________________
> R-SIG-Mac mailing list
> R-SIG-Mac using r-project.org
> https://stat.ethz.ch/mailman/listinfo/r-sig-mac

More information about the R-SIG-Mac mailing list