[R-SIG-Mac] Using cairo on arm64 macOS

Jan Netík net|kj@ @end|ng |rom gm@||@com
Wed Mar 16 14:41:00 CET 2022


This is a repost of a topic which I have accidentally posted on r-devel mailing list:

first, let me appreciate the efforts around "Apple Silicone" builds of R, works like a charm! However, I have found recently that this build does not have cairo in capabilities() and in turn I cannot use cairo_pdf device. Intel build has cairo readily available, but M1 does not. I have done various attempts on installing cairo using brew or install.package("Cairo"); maybe the most preferable way is to follow https://mac.r-project.org/bin/, but that also failed stating "architecture aarch64 is not supported on os darwin20, only available architectures: x86_64arm64". I have also tried downloading cairo from https://mac.r-project.org/bin/darwin20/arm64/ and copying it into opt/R/arm64, but with no success... Nor current devel R worked for me in that issue.

I think that I overlooked something, maybe around installing cairo to opts/R/arm64 (is it really mere copying?). In that case I would edit the docs and websites around the Apple Silicone build to better clarify what needs to be done, but I may be that cairo is just not yet supported.

Anyway many thank for looking into this!


More information about the R-SIG-Mac mailing list