[R-SIG-Mac] No labels in plots - none of the solutions that I've come across have worked

J Greenbaum jgb@um @end|ng |rom gm@||@com
Wed Jun 17 08:00:03 CEST 2020

Hi all,

I'm having what appears to be a relatively common problem in R under macOS
in that text is not displaying in my plots.  This used to work just fine
for me, and still does on my other machines, except for my laptop (MBP
16).  The issue seemed to coincide with my upgrade to 10.15.5.

When plotting, I get warnings similar to:

no font could be found for family "Arial"

I've tried every solution that I've come across on this issue including
finding duplicate fonts in 'Font Book', ensuring they all validate
properly, and I've even gone nuclear and completely reinstalled my OS!
I've tried installing the official R package as well as the homebrew R
package.  I've also validated it's not my user account by reproducing the
issue under different accounts. Nothing works.

I would love some help in tracking this issue down.  Any insight would be
much appreciated.

Thank you!


	[[alternative HTML version deleted]]

More information about the R-SIG-Mac mailing list