[R-SIG-Mac] Problem with CHECK --as-cran on Catalina

Jeff Newmiller jdnewm|| @end|ng |rom dcn@d@v|@@c@@u@
Sun Jun 7 19:44:44 CEST 2020

No, it has been this way for longer than I have been building packages. I think the variable that determines whether a check of the working files will break is what additional files that get filtered out when you build the source package. Anyway, checking the source package is the recommended practice.

On June 7, 2020 10:32:45 AM PDT, Carl Witthoft <carl using witthoft.com> wrote:
>Looks like I found a way to succeed.
>If I type
>R CMD CHECK --as-cran  mypackage.tar.gz
>then I get a successful check executed.  So this is a bit different
>the "good old days" under R 3.6.X  and my old 10.11 OSX, but now I know
>how to get it done.
>On 6/6/20 4:29 PM, Jeff Newmiller wrote:
>> AFAIK tgz is one possible file name extension equivalent to .tar.gz,
>which implies gzip compression, so I think Bob was just being a bit
>sloppy when he wrote tar.tgz.
>> Key point is not that a particular compression makes a difference,
>but that the check needs to be run on a source archive rather than the
>in-place source you have been editing. He was confirming that you are
>making that file and specifying it when checking.
>> On June 6, 2020 11:59:24 AM PDT, Carl Witthoft <carl using witthoft.com>
>>> I plead ignorance here: I don't see an option to create .tgz . The
>>> R CMD BUILD --help just lists "gzip" (default), "none", "bzip2",
>>> .Does one of those create the .tgz -type compression?
>>> Carl
>>> On 6/6/20 2:37 PM, Bob Rudis wrote:
>>>> Does it still do it if you build a tar.tgz archive and run it on
>>> that?
>>>> I could not dup your problem, but when I tried to run it on a
>>>> of my packages that work fine with tar.gz (I use Authors using R) in dir
>>> (`R
>>>> CMD check --as-cran .` or parent dir and specify the pkg dir) I
>>>>       Required field missing or empty:
>>>>         ‘Author’
>>>> (running last R 4.0.1 beta before the release of R 4.0.1, latest
>>>> Catalina beta AND R 4.0.0 on ubuntu)
>>>> So, def something strange going on.
>>>> On Sat, Jun 6, 2020 at 12:47 PM Carl Witthoft <carl using witthoft.com>
>>> wrote:
>>>>> Hi,
>>>>> I recently upgraded to a new iMac w/ Catalina.  Something really
>>> strange
>>>>> is happening when I try to run "R CMD CHECK --as-cran  " .
>>>>> If I run it on various older packages that have previously passed
>>> the
>>>>> check, all is well.
>>>>> I am writing a new package, and here's the response I get:
>>>>> * using log directory ‘/Users/cgw/Rgames/fitConic.Rcheck’
>>>>> * using R version 4.0.0 (2020-04-24)
>>>>> * using platform: x86_64-apple-darwin17.0 (64-bit)
>>>>> * using session charset: UTF-8
>>>>> * using option ‘--as-cran’
>>>>> * checking for file ‘fitConic/DESCRIPTION’ ... OK
>>>>> * this is package ‘fitConic’ version ‘1.0’
>>>>> * checking CRAN incoming feasibility ...Error:  file
>>>>> does not exist
>>>>> Execution halted
>>>>> This happens whether I run R CMD CHECK  from the parent dirctory
>>>>> /Users/cgw/Rgames  or from the source directory
>>> /Users/cgw/Rgames/fitConic .
>>>>> I verified I can edit the DESCRIPTION file in my previous packages
>>>>> still pass the check.  I even took one of those old DESCRIPTION
>>> files
>>>>> and put it into the fitConic directory, and changed only the
>>> "Package:"
>>>>> line  .
>>>>> I'm guessing that last error message is not telling me what
>>>>> went wrong, but I'm at a loss as to why this new package fails.
>>> I've
>>>>> created a new directory and moved all my files (DESCRIPTION,
>>>>> and the R & man folders) over. No luck.
>>>>> Is this a hangup somewhere in R 4.0 for OSX, or is there something
>>> else
>>>>> going on?   (do I need, for example to do something to give
>>> more
>>>>> permissions, or some other called app? )
>>>>> thanks
>>>>> --
>>>>> Carl Witthoft
>>>>> carl using witthoft.com
>>>>> resume: https://app.box.com/file/498153801347
>>>>> _______________________________________________
>>>>> R-SIG-Mac mailing list
>>>>> R-SIG-Mac using r-project.org
>>>>> https://stat.ethz.ch/mailman/listinfo/r-sig-mac

Sent from my phone. Please excuse my brevity.

More information about the R-SIG-Mac mailing list