[R-SIG-Mac] R commander fonts on R 3.4.0

Fox, John jfox at mcmaster.ca
Wed May 10 03:52:57 CEST 2017

Dear David,

Jose and I corresponded earlier today, and I can’t duplicate his problem
on two MacBook Pros, both with apparently the same setup as Jose’s: macOS
Sierra, R 3.4.0, Rcmdr 2.3-2, and XQuartz 2.7.11 (i.e., all current

If the problem were with availability of X11 fonts, why would the fonts
appear properly for him with R 3.3.3 but not R 3.4.0?

I thought that someone more familiar with Macs than I am might spot the
cause of the problem from Jose’s screenshot, and so I suggested that he
write to the R-SIG-Mac list.


John Fox, Professor
McMaster University
Hamilton, Ontario, Canada
Web: http://socserv.mcmaster.ca/jfox/

On 2017-05-09, 6:45 PM, "R-SIG-Mac on behalf of David Winsemius"
<r-sig-mac-bounces at r-project.org on behalf of dwinsemius at comcast.net>

>> On May 9, 2017, at 3:08 PM, Jose G Conde Santiago via R-SIG-Mac
>><r-sig-mac at r-project.org> wrote:
>> Hello,
>> I recently upgraded to R 3.4.0, but now I get very poor fonts from
>>Rcmdr 2.3-2 as shown below:
>> <Dialog.png>
>I'm not an Rcmdr user but I tried bringing a current version up. (I
>included a request to install Rcmdr with all dependencies but X11
>complained that aplpack was missing and that needed to be installed as
>well.)  Seems you don't like teh proportionally space serif font you are
>seeing which was different than what I saw. Think you might want to show
>what this returns for you
>[1] "serif"        "sans"         "mono"         "Times"
>[6] "CyrTimes"     "CyrHelvetica" "Arial"        "Mincho"
>> X11Fonts()$serif
>[1] "-*-times-%s-%s-*-*-%d-*-*-*-*-*-*-*"
>I'm running R 3.4.0, El Cap, XQuartz 2.7.11 (xorg-server 1.18.4)  and
>that won't change since my box is "end of life" per Apple's inflexible OS
>I tried running your test code and it seemed to lock up my X11 session as
>well as my R console (Perhaps this is due to running Rcmder in the R.app
>> I reloaded the older version of R (3.3.3), ran Rcmdr and the problem
>>disappeared. I downloaded R 3.4.0 again and the problem with Rcmdr
>> I read a previous post on the list regarding an issue with Rcmdr and
>>followed your suggestions to that posting:
>> 1. The following test went well with R 3.4.0:
>>> > library (tcltk)
>>> > tk_messageBox(message="test")
>>> [1] "ok"
>>> > 
>> 2. Ran R 3.4.0 from the terminal, and then ran R Commander. The problem
>> I am running XQuartz 2.7.11. My machine is an iMac (27-inch, Late
>>2012); Processor 3.4 GHz Intel Core i7, with 32 GB RAM. Graphics: NVIDIA
>>GeForce GTX 675MX 1024 MB. OS X Sierra 10.12.4.
>> I will appreciate any suggestions.
>> Thanks in advance.
>> José
>> José G. Conde, MD, MPH
>> Professor, School of Medicine
>> Director, CentIT2
>> UPR Medical Sciences Campus
>> Tel  (787) 763-9401 Fax (787) 758-5206
>> Email: jose.conde1 at upr.edu
>> URL: http://rcmi.rcm.upr.edu
>> _______________________________________________
>> R-SIG-Mac mailing list
>> R-SIG-Mac at r-project.org
>> https://stat.ethz.ch/mailman/listinfo/r-sig-mac
>David Winsemius
>Alameda, CA, USA
>R-SIG-Mac mailing list
>R-SIG-Mac at r-project.org

More information about the R-SIG-Mac mailing list