[R-SIG-Mac] R-console 3.0.2 & R-studio 0.97.551 problem with mac OS X 10.8.3

R. Michael Weylandt <michael.weylandt@gmail.com> michael.weylandt at gmail.com
Sun Sep 29 16:47:07 CEST 2013

On Sep 29, 2013, at 10:31, 陈妍锦 <cyj901027 at gmail.com> wrote:

> Hi all. I am experiencing very annoying R software problems and am looking for help.
> I am using mac OS X 10.8.3. The version for R-studio is 0.97.551. The version for R-console is 3.0.2. I got similar problems in R-studio and R-console. 
> For R-studio, it often happens that when I type a command in the console window and press enter, the command will disappear and leave nothing in the command history. I even can't retrieve the previous command by the up arrow. I have to retype the command. It happens very often, with probability nearly 50%.
> For R-console, almost similar problems. Many commands got stuck. I have to force them to stop.
> This scenario happens for even every command, like 'library(Rlab)', 'rbern(100, 0.1)', etc.
> I've tried several methods, including uninstall both R-console and R-studio, even have tried to uninstall them through mac terminal. Even I put these two software in the recycle bin, and uninstall them on terminal, R is still there with mac ports when I enter R in the terminal. The problem exists. I don't know whether my mac ports sucks.

Probably -- I know Simon (= R on Mac god) doesn't like MacPorts and given that it's hitting all front ends, it might be their build. 

Wipe it entirely from your system (such that typing "R" at the terminal can find anything, not just deleting the items in your applications directory) and reinstall using the CRAN binary. 

Afraid I can't help with the uninstall -- don use MacPorts myself. 


> I do appreciate your help<330.gif>
> _______________________________________________
> R-SIG-Mac mailing list
> R-SIG-Mac at r-project.org
> https://stat.ethz.ch/mailman/listinfo/r-sig-mac

More information about the R-SIG-Mac mailing list