[R-SIG-Mac] similar problems installing Rcmdr with R.

John Fox jfox at mcmaster.ca
Tue Sep 24 20:34:24 CEST 2013

Dear Mark,

> -----Original Message-----
> From: Hebblewhite, Mark [mailto:Mark.Hebblewhite at umontana.edu]
> Sent: Tuesday, September 24, 2013 12:32 PM
> To: John Fox
> Cc: r-sig-mac at r-project.org
> Subject: Re: [R-SIG-Mac] similar problems installing Rcmdr with R.
> Yes, the solution proposed by Rodney Sparapani below worked to fix my
> problem, but was a slightly different command than proposed to Sarah
> earlier.
> Thanks very much Rodney! It will be challenging to fix this problem,
> however, for other 'naïve' users of MAC if the solution is different
> each
> time.

Just to be clear:

	sudo chmod a+rx /usr/local/*

didn't work, but

	sudo zsh
	chmod -R 755 /usr/local

did work?

Frankly, I don't get that, since the first command should insure that
everyone has (at least) read and execute permission (i.e., level 5).

I think that I'll add a trouble-shooting section to the Rcmdr Mac
installation notes, but I would like to understand why one approach worked
here and not the other.


> Thanks very much John, Simon and Rodney!
> On 09/24/2013 07:45 AM, Hebblewhite, Mark wrote:
> >7. From previous posts on this list serve
> >[http://grokbase.com/t/r/r-sig-mac/138nv3tj17/unable-to-load-rcmdr-
> with-r-
> >3
> >-0-1-on-a-mac-os-x-10-8-3] I followed this set of instructions to see
> >whether there were problems with my permissions:
> >
> >>>system("ls -ld /usr/local /usr/local/lib /usr/local/lib/libtcl*")
> >ls: /usr/local/lib: Permission denied
> >ls: /usr/local/lib/libtcl*: Permission denied
> >drwx------  8 root  wheel  272 Sep 24 10:21 /usr/local
> >
> >
> >8. But in my disk utilities I can see no clear disk permissions
> related to
> >R. I ran repair disk permissions earlier today and there was 1 R
> problem
> >but that¹s been apparently fixed.
> Hi Mark:
> I am assuming you came to Mac from Windows, rather than UNIX/Linux,
> right?  On Mac OS X (and UNIX/Linux in general), you need to have
> permission to read/write/execute files.  But, I think you can fix
> this rather easily.  In a terminal...
> % sudo zsh
> # chmod -R 755 /usr/local
> >

More information about the R-SIG-Mac mailing list