[R-SIG-Mac] similar problems installing Rcmdr with R.

Hebblewhite, Mark Mark.Hebblewhite at umontana.edu
Tue Sep 24 14:45:38 CEST 2013

I have recently installed R 3.0.1 on my MacBook Pro OS  X 10.8.5 (very new
version), and am experiencing similar problems that Sarah Hardy posted
almost a month ago. I similarly teach an introduction to R course to about
20 graduate students, many of whom use Mac's, but luckily not this
semester. I have used R for > 6 years, but am new (1 year) to MACs, but
expect that if I'm having this problem with 10.8.5, then others must be

 I have read through the entire thread of solutions for this problem on
this list serve, the notes on Joseph Fox's webpage
 and have tried to do my absolute best to fix the problem myself and with
a colleague.  Here is a summary of my particulars:

1. I have a Mac OS X 10.8.5, and updated everything today.
2. I also installed the XQuartz package today, version 2.7.4 from last
Sept 2012.
3. I uninstalled R manually from my MAC (both moving old version to the
trash and cleaning out R directories)
4. I re-installed R (R 3.0.1 GUI 1.61 Snow Leopard build (6492) directly
from the CRAN (Italy) using this command:

install.packages("Rcmdr", dependencies = TRUE)

	5. I then followed the instructions for downloading Rcmdr package in both
the command line and from the R.app menu. I have also tried it from two
different CRAN sites. It downloaded and installed apparently fine as it
appears in my library files (version dated august 22)

The downloaded binary packages are in

6. 	No matter what series of these steps I take, I receive the similar
error message as others:


Error : .onLoad failed in loadNamespace() for 'tcltk', details:
  call: dyn.load(file, DLLpath = DLLpath, ...)
  error: unable to load shared object
/libs/tcltk.so, 10): Library not loaded: /usr/local/lib/libtcl8.6.dylib
  Referenced from: 
  Reason: no suitable image found.  Did find:
	/usr/local/lib/libtcl8.6.dylib: stat() failed with errno=13
	/usr/local/lib/libtcl8.6.dylib: stat() failed with errno=13
Error: package or namespace load failed for ŒRcmdr¹

7. From previous posts on this list serve
-0-1-on-a-mac-os-x-10-8-3] I followed this set of instructions to see
whether there were problems with my permissions:

> system("ls -ld /usr/local /usr/local/lib /usr/local/lib/libtcl*")
ls: /usr/local/lib: Permission denied
ls: /usr/local/lib/libtcl*: Permission denied
drwx------  8 root  wheel  272 Sep 24 10:21 /usr/local

8. But in my disk utilities I can see no clear disk permissions related to
R. I ran repair disk permissions earlier today and there was 1 R problem
but that¹s been apparently fixed.

My own troubleshooting abilities are at an end.

As best I can determine, it seems as if the XQuartz version I downloaded
might not be working with my Mac OSX 10.8.5, but beyond that I really have
no clue how best to proceed.

thanks very much for your patience with this problem and with me if my
query is naïve in anyway.


Mark Hebblewhite
Wildlife Biology Program
Department of Ecosystem and Conservation Sciences
College of Forestry and Conservation
University of Montana
32 Campus Drive
Missoula, MT, 59812
Phone: 1-406-243-6675
Email: mark.hebblewhite at umontana.edu
Website: http://www.cfc.umt.edu/Heblab/

-------------- next part --------------
A non-text attachment was scrubbed...
Name: BB12F55E-E208-43FA-9D98-CCD7374AA5C9[1].png
Type: image/png
Size: 44276 bytes
Desc: BB12F55E-E208-43FA-9D98-CCD7374AA5C9[1].png
URL: <https://stat.ethz.ch/pipermail/r-sig-mac/attachments/20130924/f3d429f2/attachment-0001.png>

More information about the R-SIG-Mac mailing list