[R-SIG-Mac] my system refuse to install rgdal

Simon Urbanek simon.urbanek at r-project.org
Fri Sep 17 23:25:33 CEST 2010

On Sep 17, 2010, at 5:02 PM, Agustin Diez Castillo wrote:

> gdal-config is in my path

apparently it's not for R otherwise you would not see that error (hint: .profile and others are NOT loaded by LS). As the error message suggests you can also provide the full path  using --with-gdal-config - have you tried that?


> I'm on 10.6.4
> I've tried both at system and at user level with the same result.
> ¿Any suggestions?
> ERROR: configuration failed for package ‘rgdal’
> * removing ‘/Users/adiez/Library/R/2.10/library/rgdal’
> The downloaded packages are in
> 	‘/private/var/folders/cv/cvYrUrtiEiuTpxH6VannjU+++TI/-Tmp-/Rtmp4GLVOJ/downloaded_packages’
> * installing *source* package ‘rgdal’ ...
> gdal-config: gdal-config
> ./configure: line 1311: gdal-config: command not found
> Error: gdal-config not found
> The gdal-config script distributed with GDAL could not be found.
> If you have not installed the GDAL libraries, you can
> download the source from  http://www.gdal.org/
> If you have installed the GDAL libraries, then make sure that
> gdal-config is in your path. Try typing gdal-config at a
> shell prompt and see if it runs. If not, use:
> --configure-args='--with-gdal-config=/usr/local/bin/gdal-config' echo with appropriate values for your installation.
> ERROR: configuration failed for package ‘rgdal’
> * removing ‘/Library/Frameworks/R.framework/Versions/2.10/Resources/library/rgdal’
> _______________________________________________
> R-SIG-Mac mailing list
> R-SIG-Mac at stat.math.ethz.ch
> https://stat.ethz.ch/mailman/listinfo/r-sig-mac

More information about the R-SIG-Mac mailing list