[R-SIG-Mac] Sweave Error

Kent Manley kent.manley at att.net
Tue Sep 7 04:46:05 CEST 2010

I just used migration assistant to move from a PPC G4 to an Intel based Mac Book Pro, and I'm having all sorts of ghosts like this, too.

Try, in the named directory below,

sudo chmod +x Sweave.engine

You'll have to give it your user password, but that should set the executable bit.

Best+ HTH,

On Sep 6, 2010, at 6:32 AM, Keith Jones wrote:

> Hi,
> I have an iMac 2.8 GHz intel Core 2 Duo, 2GB 800 MHz SDRAM, OSX 10.5.8, TeXShop 2.36, and R 2.11.1.  I have all the Sweave files in the TeXShop ~/Engines folder.
> It has been six or seven months since I last tried to compile a Rnw file in TeXShop and now I get the following error:
> /Users/keithjones/Library/TeXShop/Engines/Sweave.engine does not have the executable bit set.
> It worked fine the last time I used it.  Has something changed in the OS?  How do I set the executable bit?
> Thanks,
> Keith Jones
> "It is Important to understand what you CAN DO before you learn to measure how WELL you seem to have DONE it." John Tukey
> _______________________________________________
> R-SIG-Mac mailing list
> R-SIG-Mac at stat.math.ethz.ch
> https://stat.ethz.ch/mailman/listinfo/r-sig-mac

More information about the R-SIG-Mac mailing list