[R-SIG-Mac] Sweave Error

Marc Schwartz marc_schwartz at me.com
Mon Sep 6 17:04:01 CEST 2010

On Sep 6, 2010, at 5:32 AM, Keith Jones wrote:

> Hi,
> I have an iMac 2.8 GHz intel Core 2 Duo, 2GB 800 MHz SDRAM, OSX 10.5.8, TeXShop 2.36, and R 2.11.1.  I have all the Sweave files in the TeXShop ~/Engines folder.
> It has been six or seven months since I last tried to compile a Rnw file in TeXShop and now I get the following error:
> /Users/keithjones/Library/TeXShop/Engines/Sweave.engine does not have the executable bit set.
> It worked fine the last time I used it.  Has something changed in the OS?  How do I set the executable bit?
> Thanks,
> Keith Jones

Strictly speaking, not an Sweave error, but an application permissions error on a third party add-on.

Go into Applications -> Utilities -> Disk Utility.

Select the HD in the left hand frame and then run Repair Disk Permissions towards the bottom of the right hand frame.

Then re-try to run the program. If that does not work, you may need to re-install the files in question.


Marc Schwartz

More information about the R-SIG-Mac mailing list