[R-SIG-Mac] [R] Optional libraries (libtiff, etc) not found

David Winsemius dwinsemius at comcast.net
Sun Sep 27 17:47:49 CEST 2009

There is sufficient circumstantial evidence to suggest you are posting  
in the wrong mailing list. Follow-up should go there.  You also have  
not posted sessionInfo() output or the error messages you are getting  
when <what-ever-it-is-that-you-have-done> that "didn't work". You  
should post in R-SIG-Mac and include the appropriate information  
requested in the Posting Guide (sessionInfo(), console output prior to  
error message, and error messages).

On Sep 27, 2009, at 10:23 AM, Wayne F wrote:

> I installed the (binary) biOps package, which can use libtiff and  
> libfftw.
> Then I used macports to install the libraries (in /opt/local/lib).  
> But I
> restart R and biOps still does not see the libraries.

There is a binary package called devpack4 at:


I don't see libtiff in there, but libjpeg which biOps requires  
(according to the docs) is in there. If you are going to compile from  
sources you should read that information carefully.
> I've tried adding symbolic links from /opt/local/lib to /usr/local/ 
> lib, I've
> added /opt/local/lib to LIBRARY_PATH, LD_LIBRARY_PATH, and
> DYLD_LIBRARY_PATH, and it doesn't work.
> Do you need to install biOps source in order for it to realize that  
> the
> libraries are there? Or something else?

I got this error when I tried to load the binary installed package:
 > library(biOps)
Error in dyn.load(file, DLLpath = DLLpath, ...) :
   unable to load shared library '/Library/Frameworks/R.framework/ 
x86_64/biOps.so, 6): Symbol not found: _TIFFClose
   Referenced from: /Library/Frameworks/R.framework/Resources/library/ 
   Expected in: dynamic lookup

Compiling from sources using the GUI Package Installer succeeded and  
the package loaded without error.

I did encounter some warnings in the check phase:

checking fftw3.h usability... no
checking fftw3.h presence... no
checking for fftw3.h... no
checking jpeglib.h usability... configure: WARNING: Can't find fftw3  
checking jpeglib.h presence... yes
checking for jpeglib.h... yes
checking tiff.h usability... no
checking tiff.h presence... no
checking for tiff.h... no
configure: WARNING: Can't find libtiff header

My scan of the compilation messages suggested that the lack of tiff  
support was not remedied in the process but I cannot be sure about  
that (see below). In the past (say a year ago) I generally needed to  
compile from sources if I were using the 64-bit GUI, but that is an  
unusual occurrence more recently. Being a UNIX-noob, I cannot tell  
whether this error was due to my being in the 64 bit configuration.   
Whether the package will do anything useful now, I cannot say:

capabilities() still reported FALSE for tiff

The first example in hte documentation produces a black square
 > jpeg()
 > p <- q <- seq(-1, 1, length=20)
 > r <- 1 - outer(p^2, q^2, "+") / 2
 > plot(imagedata(r))
 > dev.off()
null device

The second example I tried produced a very pretty picture of a flower:

 > x <- readJpeg(system.file("samples", "violet.jpg", package="biOps"))
 > cat("Image Type", imageType(x))
Image Type rgb
 > x
size:  499 x 333
type:  rgb
 > plot(x)

(And plotting to the tiff device produces a nice flower, despite what  
capabilities says.)

Best of luck;


David Winsemius, MD
Heritage Laboratories
West Hartford, CT

 > sessionInfo()
R version 2.9.2 (2009-08-24)


attached base packages:
[1] splines   stats     graphics  grDevices utils     datasets   
methods   base

other attached packages:
[1] biOps_0.2.1     gdata_2.6.1     Design_2.3-0    foreign_0.8-37   
[6] survival_2.35-7

loaded via a namespace (and not attached):
[1] cluster_1.12.0  grid_2.9.2      gtools_2.6.1    lattice_0.17-25  

More information about the R-SIG-Mac mailing list