[R-SIG-Mac] Error loading packages, command 'tar' missing from path?

Andrew J. Rominger rominger at stanford.edu
Thu Mar 5 10:22:33 CET 2009

Thanks to all for your help and suggestions.  I apparently did somehow delete tar.  In the terminal i get:

$ which tar
no tar in /usr/bin /bin /usr/sbin /sbin /usr/local/bin /usr/X11R6/bin

Sorry to be a little slow, but I'm not familiar with working in the terminal so I'm sure there is a way to "reset" the path--but I don't know how to do it.  And I don't want to mess anything up any more!  Could anyone direct me as to where I can properly learn about resetting the path to include tar?

Thanks very much--

----- Original Message -----
From: "Simon Urbanek" <simon.urbanek at r-project.org>
To: "Andrew J. Rominger" <rominger at stanford.edu>
Cc: r-sig-mac at stat.math.ethz.ch
Sent: Wednesday, March 4, 2009 7:31:26 AM GMT -08:00 US/Canada Pacific
Subject: Re: [R-SIG-Mac] Error loading packages, command 'tar' missing from path?

On Mar 3, 2009, at 17:52 , Andrew J. Rominger wrote:

> Hello all,
> My appologies for any possible cross-posting--I originally posted a  
> version of this to R-Help, but was refered to r-sig-mac because  
> apparently my problem is mac-specific.

It is specific to your system - experience (see archives) shows that  
either you somehow changed the default PATH and it doesn't include / 
usr/bin anymore or you have somehow deleted tar (/usr/bin/tar).


> I'm running R2.8.1 on a Mac OS 10.4.11.  While trying to install the  
> package gdata, I was presented with the following (error at end of  
> report):
>> install.packages("gdata")
> also installing the dependency ‘gtools’
> trying URL 'http://cran.stat.ucla.edu/bin/macosx/universal/contrib/2.8/gtools_2.5.0-1.tgz'
> Content type 'application/x-tar' length 85484 bytes (83 Kb)
> opened URL
> ==================================================
> downloaded 83 Kb
> trying URL 'http://cran.stat.ucla.edu/bin/macosx/universal/contrib/2.8/gdata_2.4.2.tgz'
> Content type 'application/x-tar' length 539301 bytes (526 Kb)
> opened URL
> ==================================================
> downloaded 526 Kb
> /bin/sh: line 1: tar: command not found
> 2009-03-02 20:42:06.081 R[357] tossing reply message sequence 3 on  
> thread 0x1ce3ae0
> Error in sprintf(gettext(fmt, domain = domain), ...) :
>  argument is missing, with no default
> It seems that 'tar' is missing which (I'm guessing) leads to an  
> error in sprintf().  I've never been presented with this error  
> before.  I tried loading various other packages and received the  
> same error.  When the error first appeared, I was running R2.5.3.   
> After upgrading to R2.8.1 the error persists.
> Thanks in advance for any help--
> Andy Rominger
> _______________________________________________
> R-SIG-Mac mailing list
> R-SIG-Mac at stat.math.ethz.ch
> https://stat.ethz.ch/mailman/listinfo/r-sig-mac

Andrew Rominger 
Department of Biology 
Stanford University 
rominger at stanford.edu 
(650) 862-6063 

More information about the R-SIG-Mac mailing list