[R-SIG-Mac] Textmate/ SWeave: Error PDF file not written to disk

Saiwing Yeung saiwing at berkeley.edu
Mon Apr 13 01:44:13 CEST 2009

I ran into the same problem today (at least the symptoms matched) and  
it took me some time to figure this out... Basically I solved this by  
copying the file Sweave.sty to the same directory as the the .rnw  
file. I suppose you can also try to add the path to Sweave.sty. But  
then, by having the file in the same directory, when you send your  
stuff to other people, it is more likely that you will include it and  
prevent your collaborators from having the same problem.

A related issue is that the "missing Sweave.sty" error isn't shown in  
the TextMate output when you run "Sweave, Typeset, & View" even though  
it looks like it should.
     run_tex "$FILE" 2>&1| latexErrWarnHtml.py -v

I haven't really looked into this though. For now I just comment out  
the redirecting part
    run_tex "$FILE" # 2>&1| latexErrWarnHtml.py -v
so that I can see the LaTeX errors.

Hope this helps,

> Dear list,
> I encountered a problem in the combination of Textmate and the SWeave
> bundle: when I start "Sweave, typeset & View", the .Rnw-file is
> processed, but the log window shows "Error: PDF file not written to
> disk" and the tex-file is not processed.
> However, the sweaving was successful, as a valid .tex-file is in the
> same folder which can be typesetted without problem.
> So, in general it works, I just want to avoid the extra step of
> opening the .tex-file and would like to see my pdf directly from
> SWeave-Bundle.
> Did anyone encounter the same problem / any suggestions for solutions?
> Best regards,
> Felix

More information about the R-SIG-Mac mailing list