[R-SIG-Mac] Mac os x graphviz-Rgraphviz problem

Kasper Daniel Hansen khansen at stat.Berkeley.EDU
Fri Feb 2 01:00:00 CET 2007

Your example works fine for me on Mac OS X ppc 10.4.8 with R-2.4.1  
and graphviz 2.12 compiled from source.

You can check your graphviz version from R by doing
R> graphvizVersion()

You have an error in the Graphviz version reported below, I assume  
you are talking about Rgraphviz' version. When you run it in the X11  
xterm (which I assume you are talking about), it seems as if some  
PATH/library settings are messed up. I don't know anything about  
Darwinports configuration, so I am afraid I cannot help much.

Getting Rgraphviz to work requires some connection between graphviz  
and Rgraphviz, and it is important for us to know what you installed,  
and especially how. I assume Darwinports compile from source? Since  
you have installed several different flavours of Graphviz, are you  
certain that you have cleaned up after you? Using the Graphviz binary  
provided by Simon Urbanek should work, but I find it  bit puzzling  
which versions (and how you installed them) you are discussing below.

So, try to reinstall Rgraphviz the way you describe below. Note what  
version of Graphviz R is linking to, both by looking at the compile  
statements when installing the package (which is why you need to  
reinstall) as well as trying
R> graphvizVersion()
and then see if something is not matching.

Btw. you are most certainly not running Graphviz 2.8 under MS  
Windows, unless you have taken major pains to do so.

Personally, Graphviz used to be a pain to install on the Mac, but the  
new version (2.12) compiled easily for me.


On Feb 1, 2007, at 1:45 PM, Gavai, Anand wrote:

> Hello everyone,
> I am having problems making Rgraphviz working with graphviz.
> I installed R from Darwin ports "http://darwinports.opendarwin.org/ 
> getdp/"
> by
>> sudo port install r
> I set my environment variables in my .bash_profile e.g export PATH=/ 
> opt/local/bin:$PATH
> I also installed other packages which are required for Rgraphviz  
> like "graphviz" and "pkgconfig" by
>> sudo port install graphviz
>> sudo port install pkgconig
> both these commands will also install dependencies which are  
> required. After this
> I start up an R session being root and get the latest version of  
> bioconductor packages by sourcing it from bioconductor website
>> source("http://www.bioconductor.org/biocLite.R")
>> biocLite()
> waited for a while and then install
>> biocLite("Rgraphviz",depend=TRUE,type="source")
> it worked fine when i opened it in a Terminal window, only the  
> loading part but when I run something like this
>> library("Rgraphviz")
>> a<-c(1,0)
>> b<-c(1,1)
>> d<-rbind(a,b)
>> graphObj = ftM2graphNEL(d)
>> plot(graphObj)
> it gives me the following error messages
> *** caught bus error ***
> address 0x40, cause 'non-existent physical address'
> Traceback:
>  1: .Call("Rgraphviz_doLayout", graph, as.integer(type), PACKAGE =  
> "Rgraphviz")
>  2: layoutGraph(g)
>  3: agopen(x, name = name, layout = TRUE, layoutType = y, attrs =  
> attrs,     nodeAttrs = nodeAttrs, edgeAttrs = edgeAttrs, subGList =  
> subGList,     recipEdges = recipEdges)
>  4: .local(x, y, ...)
>  5: plot(graphObj)
>  6: plot(graphObj)
> Possible actions:
> 1: abort (with core dump)
> 2: normal R exit
> 3: exit R without saving workspace
> 4: exit R saving workspace
> Selection:
> I cannot put here the sessionInfo() as i need to abort it, the
> the Graphviz version i have is 1.310.  I also tried to install and  
> configure 2.8 previously with no luck.
> in  X11
> when i load this library("Rgraphviz") in X11 interface it gives  
> following error message
> Error in dyn.load(x, as.logical(local), as.logical(now)) :
>         unable to load shared library '/Library/Frameworks/ 
> R.framework/Resources/library/Rgraphviz/libs/i386/Rgraphviz.so':
>   dlopen(/Library/Frameworks/R.framework/Resources/library/ 
> Rgraphviz/libs/i386/Rgraphviz.so, 6): Symbol not found: _agfstnode
>   Referenced from: /Library/Frameworks/R.framework/Resources/ 
> library/Rgraphviz/libs/i386/Rgraphviz.so
>   Expected in: dynamic lookup
> Error: .onLoad failed in 'loadNamespace' for 'Rgraphviz'
> Error: package/namespace load failed for 'Rgraphviz'
> the sessionInfo() here is
>> sessionInfo()
> R version 2.4.1 (2006-12-18)
> i386-apple-darwin8.8.1
> locale:
> C
> attached base packages:
> [1] "tools"     "stats"     "graphics"  "grDevices" "utils"      
> "datasets"
> [7] "methods"   "base"
> other attached packages:
> geneplotter    annotate     Biobase       graph
>    "1.12.0"    "1.12.1"    "1.12.2"    "1.12.0"
> Any help in this regard is appreciated. I had simimar problem in  
> the past with Suse Linux we managed to solve it, and my Windows  
> station is working fine with Graphviz 2.8 and Rgraphviz
> only my mac system (intel tiger) is a bit of a problem. I manually  
> tried to install graphviz and Rgraphviz using the source files and  
> setting LD_LIBRARY_PATH and PKG_LIBRARY_PATH but in vain the only  
> way to install them together without errors is through a darwinport.
> Regards,
> Anand
> _______________________________________________
> R-SIG-Mac mailing list
> R-SIG-Mac at stat.math.ethz.ch
> https://stat.ethz.ch/mailman/listinfo/r-sig-mac

More information about the R-SIG-Mac mailing list