[R-SIG-Mac] Mac os x graphviz-Rgraphviz problem

Gavai, Anand Anand.Gavai at wur.nl
Thu Feb 1 22:45:51 CET 2007

Hello everyone,
I am having problems making Rgraphviz working with graphviz.
I installed R from Darwin ports "http://darwinports.opendarwin.org/getdp/"

>sudo port install r

I set my environment variables in my .bash_profile e.g export PATH=/opt/local/bin:$PATH

I also installed other packages which are required for Rgraphviz like "graphviz" and "pkgconfig" by

>sudo port install graphviz

>sudo port install pkgconig 

both these commands will also install dependencies which are required. After this

I start up an R session being root and get the latest version of bioconductor packages by sourcing it from bioconductor website


waited for a while and then install


it worked fine when i opened it in a Terminal window, only the loading part but when I run something like this

>graphObj = ftM2graphNEL(d)
it gives me the following error messages

*** caught bus error ***
address 0x40, cause 'non-existent physical address'

 1: .Call("Rgraphviz_doLayout", graph, as.integer(type), PACKAGE = "Rgraphviz")
 2: layoutGraph(g)
 3: agopen(x, name = name, layout = TRUE, layoutType = y, attrs = attrs,     nodeAttrs = nodeAttrs, edgeAttrs = edgeAttrs, subGList = subGList,     recipEdges = recipEdges)
 4: .local(x, y, ...)
 5: plot(graphObj)
 6: plot(graphObj)

Possible actions:
1: abort (with core dump)
2: normal R exit
3: exit R without saving workspace
4: exit R saving workspace

I cannot put here the sessionInfo() as i need to abort it, the 

the Graphviz version i have is 1.310.  I also tried to install and configure 2.8 previously with no luck.

in  X11
when i load this library("Rgraphviz") in X11 interface it gives following error message

Error in dyn.load(x, as.logical(local), as.logical(now)) : 
        unable to load shared library '/Library/Frameworks/R.framework/Resources/library/Rgraphviz/libs/i386/Rgraphviz.so':
  dlopen(/Library/Frameworks/R.framework/Resources/library/Rgraphviz/libs/i386/Rgraphviz.so, 6): Symbol not found: _agfstnode
  Referenced from: /Library/Frameworks/R.framework/Resources/library/Rgraphviz/libs/i386/Rgraphviz.so
  Expected in: dynamic lookup
Error: .onLoad failed in 'loadNamespace' for 'Rgraphviz'
Error: package/namespace load failed for 'Rgraphviz'

the sessionInfo() here is

> sessionInfo()
R version 2.4.1 (2006-12-18) 


attached base packages:
[1] "tools"     "stats"     "graphics"  "grDevices" "utils"     "datasets" 
[7] "methods"   "base"     

other attached packages:
geneplotter    annotate     Biobase       graph 
   "1.12.0"    "1.12.1"    "1.12.2"    "1.12.0" 

Any help in this regard is appreciated. I had simimar problem in the past with Suse Linux we managed to solve it, and my Windows station is working fine with Graphviz 2.8 and Rgraphviz

only my mac system (intel tiger) is a bit of a problem. I manually tried to install graphviz and Rgraphviz using the source files and setting LD_LIBRARY_PATH and PKG_LIBRARY_PATH but in vain the only way to install them together without errors is through a darwinport.


More information about the R-SIG-Mac mailing list