[R-SIG-Mac] Does preprocessCore do ppc64?

Prof Brian Ripley ripley at stats.ox.ac.uk
Thu Dec 13 18:00:36 CET 2007

The short answer is that the BioC binary packages are not 64-bit.  But 
then neither is the CRAN build of R 2.6.1 nor the CRAN binary packages.

And very likely you are running a 32-bit R.

On Thu, 13 Dec 2007, Loren Engrav wrote:

> I tried
> options(arch="ppc64") in Rprofile
> and seems to have worked,

I am sure it 'worked' for some value of 'worked', but what do you think it 
did?  You can't change the architecture of a running R process (and you 
need a running R process to use R code ...).  You find out whether the 
process is 64-bit by checking

.Machine$sizeof.pointer == 8

and R.version$arch will also indicate the architecture name (x86_64 on my 
Macintel builds).

The sub-architecture (if any) of the running process is given by 
.Platform$r_arch and the user cannot change it (it was set at configure 
time).  From the output below, that is 'ppc'.  Not only do the 
architectures need to match, but do the sub-architecture settings: this is 
easy to achieve when building everything yourself, but not when taking 
binaries built on different systems by different people at different 

So, it seems

- you are running a 32-bit R.
- you are missing a Fortran library.

Please do try to deduce from the output what the problem is, not guess and 
never test your guesses.

> I think R.app is ppc64 in Leopard

The CRAN build of 2.6.1 is not, and you haven't told us which build you 
are using.

AFAIK if you want 64-bit, you need to build packages from sources.

How to set all this up is AFAIK not fully documented, for the very good 
reason that it is *experimental*.  My understanding is that it is intended 
to support 64-bit MacOS binary builds from R 2.7.0 only.

> But affy will not load as requires preprocessCore
> Library(preprocessCore) returns
> Error in dyn.load(file, ...) :
>  unable to load shared library
> '/Library/Frameworks/R.framework/Resources/library/preprocessCore/libs/ppc/p
> reprocessCore.so':
> dlopen(/Library/Frameworks/R.framework/Resources/library/preprocessCore/libs
> /ppc/preprocessCore.so, 5): Library not loaded:
> /Library/Frameworks/R.framework/Versions/2.6/Resources/lib/libgfortran.2.dyl
> ib
>  Referenced from:
> /Library/Frameworks/R.framework/Resources/library/preprocessCore/libs/ppc/pr
> eprocessCore.so
>  Reason: image not found
> Error in library(preprocessCore) : .First.lib failed for 'preprocessCore'
> I check libs in preprocessCore and find i386 and ppc, no ppc64
> Does this mean preprocessCore as it stands does not do ppc64? Or I am
> getting the wrong one? Or I must build 64bit? Or?
> The original thread is in Bio but this seems like a Mac specific question
> Thank you

Brian D. Ripley,                  ripley at stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

More information about the R-SIG-Mac mailing list