[R-SIG-Mac] RGL again

Bill Northcott w.northcott at unsw.edu.au
Thu Jul 21 07:44:57 CEST 2005

On 20/07/2005, at 7:08 PM, r-sig-mac-request at stat.math.ethz.ch wrote:
> on Tiger, with R 2.1.1 from CRAN, if you install rgl with
> install.packages("rgl",type="source"), the rgl package builds fine
> (apart for small ld warnings) but the result is as reported by
> Anestis. If you don't have libpng in the system this doesn't hurt
> compilation.
> You can install libpng in your system but this doesn't fix the  
> problem.
How does the build work?  As far as I could see the code in scene.cpp: 
1993-1994 is clearly incompatible with Apple's OpenGL header file.   
Perhaps it is because you are using gcc-3.3 which does not recognise  
the error.


More information about the R-SIG-Mac mailing list