[R-SIG-Mac] library version mismatch ?

Simon Urbanek simon.urbanek at r-project.org
Fri Feb 4 20:07:16 CET 2005

On Feb 4, 2005, at 11:31 AM, Paul Rathouz wrote:

> Hi -- I am using the new R 2.0.1 with / without the Cocoa GUI.  At 
> various
> times I am getting the following "version mismatch" errors for 
> libraries.
> Can I fix this? -- pr

Yes, remove the offending libraries. Obviously you are running Panther 
which comes with both libxml and libiconv that are newer than whatever 
you installed in /usr/local/lib. Removing those old libraries usually 
solves the problem. (BTW: this was mentioned on this list several times 
and is also mentioned on the Mac GUI pages).


More information about the R-SIG-Mac mailing list