[R-SIG-Mac] RMySQL and MySQL 5.0? (was Re: RMySQL and '_fprintf$LDBLStub' symbol not found)

Paul Shannon pshannon at systemsbiology.org
Mon Dec 5 23:53:22 CET 2005

Simon asks:

  > can you, please, supply us with some critical details such as how you  
  > installed and/or compiled RMySQL and whether you have a custom or  
  > CRAN version of R?

Gene offered:

  > I just had (and posted about) the exact same error message.  I found  
  > it went away after updating Xcode to 2.2.  I also made a change to  
  > SHLIB (though I don't know if that made a difference), which I can  
  > look up when I am at my other computer.

and Franklin said:

  > hi.  you may have found my postings on this topic in the archives
  > from about a month back.  i had somewhat different problems with
  > RMySQL, but all my problems were resolved after I re-installed
  > MySQL from source and RMySQL from source (both with default
  > compiler 3.3).

I used R 2.1.1, installed from the CRAN binary.  RMySQL I built from source, version 0.5-5,
on top of XML (0.97-8)  and DBI (0.1-9).

I did all this at home, on OSX 10.4.3, but only after installing the latest 
MySQL binary -- version 5.0.16-standard.  

Repeating the installation at work, using MySQSL 4.1.10-max, everything worked fine.
I'm afraid to upgrade MySQL from 4.1. to 5.0.  

Has anyone else had any luck with MySQL 5.0 and RMySQL?


 - Paul

More information about the R-SIG-Mac mailing list