[Fwd: Re: [R-SIG-Mac] Installing Bioconductor 1.5 on R 2.0 for OS X]

Michael Redmond redmond at stat.wisc.edu
Tue Nov 9 00:07:14 CET 2004

Well,  I am at a loss...
Just after I sent this message to you, I tried one more time on the 
Powerbook, and now it appears to be successfully executing getBioC. I 
wish I new what I did differently. So far, it appears to be compiling 
successfully. I won't know until a lot later. I don't think the 
bioconductor default installations use g77. I need to install DNAcopy 
which is where I had problems in the past.

I will have to wait to try this again on the XServe. It is down at the 
moment for some hardware work.

-------- Original Message --------
Subject: 	Re: [R-SIG-Mac] Installing Bioconductor 1.5 on R 2.0 for OS X
Date: 	Mon, 08 Nov 2004 16:21:19 -0600
From: 	Michael Redmond <redmond at cs.wisc.edu>
Reply-To: 	redmond at cs.wisc.edu
Organization: 	Dept. of Statistics, UW-Madison
To: 	Byron Ellis <ellis at stat.harvard.edu>
CC: 	r-sig-mac at stat.math.ethz.ch
References: 	<418805F8.3080505 at stat.wisc.edu> 
<A9350DA4-2D1F-11D9-9AC4-000D93C24D64 at stat.harvard.edu>

I have been having some success with R installation by replacing the 
fink version of g77 with the sourceforge version. So thanks very much 
for that info.

Now that I have a good R base system compiled on OS X (I am trying  both 
on a Powerbook for testing and on the XServe), I have been trying to 
load bioconductor to test compile with the sourceforge g77, but with no 
success over the last week. Something seems to have changed, since I was 
able to get further along before then.

On the Powebook, I do the standard connect to 
http://www.bioconductor.org/getBioC.R and the do the getBioC(). It spins 
for a few seconds, then gives an error message "Error in getBioC()" but 
with no additional diagnostic information. This is the same if I ask for 
default or specific packages. I also tried "verbose = TRUE" and got no 
additional info. When I try on the XServe, I get an error message "Error 
in file(file, "wb") : unable to open connection".

I am sure that I wasn't getting these messages when I first tried 
loading bioconductor to the XServe.

Any idea of what is up?
Mike Redmond
Byron Ellis wrote:

> On Nov 2, 2004, at 2:11 PM, Michael Redmond wrote:
>> I have a working version of R 2.0 with option packages installed on 
>> an OS X 10.3.5 system. Option packages were installed with 
>> install.binaries option and that seemed to work. Install using 
>> sources failed.
>> I tried installing bioconductor from sources and got mixed results 
>> (at best). Some packages failed to install (annotate, graph, 
>> Rgraphviz and maybe XML and possibly others). I also need to install 
>> arrayCGH to get DNAcopy. That uses the g77 compiler and failes with a 
>> mismatch of gcc library versions. I have g77 from fink.
> You want the g77 from http://hpc.sourceforge.net---the fink g77 has 
> never worked properly for me (actually, thats a general statement 
> about fink for me :-) )
>> Is there a install.binary option for bioconductor and some of the 
>> bioconductor contributed packages (specifically  arrayCGH)? If not 
>> now, when (if ever). If never, I may need some help to fix compile 
>> errors trying from source.
> Jan De Leeuw usually wraps up the latest Bioconductor release into his 
> "Batteries Included" version of R. I don't think there's a dedicated 
> OS X machine doing binary builds anymore (IIRC, there used to be one 
> doing the nightly smoke test). Unfortunately, OS X is probably the 
> most finicky platform at the moment as well for that reason.
>> I am working on this for an Apple 4 node XServe to see if it can be 
>> used  under the iNquiry portal for R/Bioconductor applications.
> Ooh! Could you ping me off list about how thats working out for you? 
> Our group has been considering one to serve some of internal 
> computational needs---we're mostly curious about how much 
> administration and configuration it requires. (i.e., do you just turn 
> it on and go?)
>> Thanks
>> Mike Redmond
>> UW-Madison Statistics
>> _______________________________________________
>> R-SIG-Mac mailing list
>> R-SIG-Mac at stat.math.ethz.ch
>> https://stat.ethz.ch/mailman/listinfo/r-sig-mac
> ---
> Byron Ellis (ellis at stat.harvard.edu)
> "Oook" -- The Librarian

R-SIG-Mac mailing list
R-SIG-Mac at stat.math.ethz.ch

More information about the R-SIG-Mac mailing list