[R-SIG-Mac] unable to install package labdsv

Denis Chabot chabotd at globetrotter.net
Thu Jul 1 16:07:15 CEST 2004


I am new to R but I'd like to learn while also reviewing statistical 
techniques that I feel will be useful to me in the near future. I found 
the labs prepared by
a very useful way to start with R. But they recommend 2 packages, Vegan 
and LabDSV.

The former is available on CRAN and I successfully installed it. The 
second can be found, as a source package (I apologize if this is not 
the proper term for it), on:

I downloaded the version for Linux/Unix:
abdsv_0.9-2.tar.gz. I tried to install the "tar.gz" file using the 
Packages menu in R, and selecting " from local files/Source Package 
file, and got:

 > install.from.file()
	npackage installation failed

The same thing happened after uncompressing that file and chosing "from 
source directory" instead.

Stefano has already guided me through installing the required material 
from the developper's CD to be able to install R and packages. I did 
this and was able to download a "source package" from CRAN and install 
it successfully.

I would like to verify if I am still doing something wrong with the 
labdsv package, or if maybe it is somehow not compatible with either 
the Mac or with the version of R that I am using (1.9.1). Would it be 
possible for somebody more experienced than myself to install that 
package on a Mac? If you succeed, I would really appreciate that you 
compress the binary package and send it to me, in case I do not succeed 
even with suggestions from this list!

With many thanks,

Denis Chabot <chabotd at dfo-mpo.gc.ca> or <chabotd at globetrotter.net>
Institut Maurice-Lamontagne, Fisheries and Oceans Canada

More information about the R-SIG-Mac mailing list