[R-sig-hpc] Error installing Rmpi over OpenMPI: Cannot find orted

Dirk Eddelbuettel edd at debian.org
Sat Nov 8 17:59:23 CET 2014

On 6 November 2014 at 12:21, Alejandro Gonzalez wrote:
| Hello List, this is my first message but I've been using your help for a
| while, thank you.
| I have a cluster of Ubuntu 14.04 machines with OpenMPI and I'm not being
| able to install Rmpi.

What happens when you try

     sudo apt-get install r-cran-rmpi 

as in most cases the pre-built binary will be just fine.

| Here are some more specs of my system:
| - I installed from sources Torque 4.2.9 and Maui 3.3.1
| - OpenMPI version is 1.8.2 (I installed this one from source too)
| - R version is 3.0.2 (This was installed with apt-get install)
| When I try to install Rmpi:
| $ sudo R CMD INSTALL Rmpi_0.6-3.tar.gz
| --configure-args="--with-mpi=/opt/openmpi"
| I get the following:
| ---
| * installing to library ‘/usr/local/lib/R/site-library’
| * installing *source* package ‘Rmpi’ ...
| checking for gcc... gcc -std=gnu99
| checking whether the C compiler works... yes
| checking for C compiler default output file name... a.out
| checking for suffix of executables...
| checking whether we are cross compiling... no
| checking for suffix of object files... o
| checking whether we are using the GNU C compiler... yes
| checking whether gcc -std=gnu99 accepts -g... yes
| checking for gcc -std=gnu99 option to accept ISO C89... none needed
| Trying to find mpi.h ...
| Found in /opt/openmpi/include
| Trying to find libmpi.so or libmpich.a ...
| Found libmpi in /opt/openmpi/lib
| checking for orted... no
| configure: error: Cannot find orted. Rmpi needs orted to run.

Given that we have an existing Debian (and Ubuntu) package which has been
built for years, "all" you need to do is to ensure that you too have what is
called the 'Build-Depends' needed to build the package.  Each Debian package
writes these down in their configuration, and here it is (and I wrapped lines
for the email)

    Build-Depends: debhelper (>= 7.0.0), cdbs, \
         r-base-dev (>= 3.1.0), \
         mpi-default-dev, mpi-default-bin

where line one just deals with Debian packaging internals, line two ensure R
is present (doh !!) and line three ensures that you have both the binaries
and headers / libraries for the default MPI implementation on your
architecture -- which is OpenMPI on most of them (and MPICH on some less
common architectures).

I do not think this has anything to do with Torque (though I could be
overlooking something, Ei-ji usually knows very very well what he is talking

But as I said: there is generally no reason to build this from source.


| ERROR: configuration failed for package ‘Rmpi’
| * removing ‘/usr/local/lib/R/site-library/Rmpi’
| ---
| I've read the Rmpi news,
| http://r.789695.n4.nabble.com/Problem-installing-Rmpi-with-Open-MPI-tt4641762.html#none
| and http://www.open-mpi.org/community/lists/devel/2012/04/10840.php and
| then tried to install Rmpi using a new build of OpenMPI, that I configured
| this way:
| $ ./configure --with-tm=/opt/torque --prefix=/opt/openmpi_disable_dlopen
| --disable-dlopen
| But I got the same error (configure: error: Cannot find orted. Rmpi needs
| orted to run.).
| Am I doing something wrong? Do you have a clue on how can I install Rmpi?
| I'd also want to understand more about what does --disable-dlopen mean, why
| it's necessary for Rmpi and what happens when I run other MPI software when
| OpenMPI has been configured with --disable-dlopen. May you share me some
| reading?
| Thanks in advance.
| Alejandro
| 	[[alternative HTML version deleted]]
| _______________________________________________
| R-sig-hpc mailing list
| R-sig-hpc at r-project.org
| https://stat.ethz.ch/mailman/listinfo/r-sig-hpc

http://dirk.eddelbuettel.com | @eddelbuettel | edd at debian.org

More information about the R-sig-hpc mailing list