[R-sig-hpc] multi-core processing on single Win7-64 computer

Allan Engelhardt allane at cybaea.com
Tue Mar 15 18:20:07 CET 2011

You could try doSMP ( 
http://cran.r-project.org/web/packages/doSMP/index.html ) or upgrade to 
Unix-type systems....  On Windows the Revolutions product may be worth 
paying for - at least everything kind of works together there and you 
have someone to complain to if it doesn't.


On 15/03/11 16:17, Timothy_Handley at nps.gov wrote:
> Hey folks, I would like to speed up some R processes by splitting tasks
> among the 2 cores on my desktop computer. There seem to be a variety of
> ways one can do this, however the obvious choices aren't working for me.
> I'm hoping that some of you may have advice.
> System: Windows 7-64, Core2 Duo CPU, R 2.12.2.
> MPI Option: I've successfully installed MPICH2 (1.3.2.p1). The test program
> (calculating pi) works via command prompt window, although the
> configuration GUI (wmpiconfig) doesn't work (known bug on 64-bit systems).
> I then installed Rmpi (0.5-9), but whenever I try to load this package
> (call "library(Rmpi)") I receive an error: Error: package 'Rmpi' is not
> installed for 'arch=x64'.  This same error was reported last November
> (http://comments.gmane.org/gmane.comp.lang.r.hpc/499), but I don't see any
> resolution.
> Sockets: The documentation for both snow and snowfall say that one can run
> parallel processes with no additional software using sockets. I've
> installed the most recent versions of both packages, and tried to set up a
> simple socket cluster.  The documentation for snow suggests the commands
>    makeCluster(c("localhost","localhost"), type="SOCK")
>    makeCluster(2, type="SOCK")
> should create a simple cluster on my workstation. However, both commands
> hang. After hitting enter, R simply sits until I lose patience (~2-3min).
> Note that ESC still functions to stop the command. Similarly, the very nice
> website here:
>    http://www.imbi.uni-freiburg.de/parallel/#overview
> explicitly says that this snowfall command
>    sfInit( parallel=TRUE, cpus=2, type="SOCK" )
> should work anywhere. Unfortunately, this also causes R to hang. I disabled
> my security software (Symantec), then retried the socket commands, but R
> still hangs.
> Any ideas would be greatly appreciated. Thanks,
> Tim Handley
> Research Assistant
> Channel Islands National Park
> (Will be working from both CHIS and SAMO)
> SAMO Phone: 805-370-2300 x2412(Mon, Tue)
> CHIS Phone: 805-658-5759 (Wed, Thu, Fri )
> _______________________________________________
> R-sig-hpc mailing list
> R-sig-hpc at r-project.org
> https://stat.ethz.ch/mailman/listinfo/r-sig-hpc

More information about the R-sig-hpc mailing list