[R-sig-hpc] launch cluster interactively?

Huang-Wen Chen hwchen at cs.nyu.edu
Thu Sep 17 03:54:21 CEST 2009

I solved the same problem by modifying system-wide hostfile. Starting 
the cluster by orterun is fine but not insides R/Rmpi/snow. This is 
because local settings, such as ~/.openmpi or environment variables, are 
ignored in Rmpi. Another way is to add host/hostfile into the 'info' 
object (via mpi.info.add) while you start the cluster. The latter might 
require openmpi 1.3 because it didn't work for me.

Whit Armstrong wrote:
> Is it no longer possible to start a cluster interactively with MPI?
> I just tried to run an old script interactively, but it now fails.
> warmstrong at research:~$ R
>> library(Rmpi)
>> library(snow)
>>  cl <- makeCluster(4,"MPI")
> [research:08918] [[33202,1],0] routed:binomial: Connection to lifeline
> [[33202,0],0] lost
> warmstrong at research:~$
> our MPI setup works with slurm and orterun.  I just can't seem to start the
> cluster from an existing R session.
> R 2.8.1, openMPI 1.3, ubuntu 9.04.
> Thanks,
> Whit
> 	[[alternative HTML version deleted]]

More information about the R-sig-hpc mailing list