[R-sig-Geo] Installation of rgdal from CRAN on MACOSX does not work

Agustin Lobo alobolistas at gmail.com
Wed Dec 29 13:48:16 CET 2010

While the installation from
works fine
the installation of rgdal from CRAN on MACOSX does not work, despite
my previous message that this issue was solved as well
(my confusion was a consequence of mixing both installations in the
same session):

> setRepositories(ind=1:2)
> install.packages("rgdal")
--- Please select a CRAN mirror for use in this session ---
probando la URL
Content type 'application/x-gzip' length 10203689 bytes (9.7 Mb)
URL abierta
downloaded 9.7 Mb

The downloaded packages are in
> require(rgdal)
Loading required package: rgdal
Loading required package: sp
Error in dyn.load(file, DLLpath = DLLpath, ...) :
  unable to load shared object
6): Library not loaded: libR.dylib
  Referenced from:
  Reason: image not found
> sessionInfo()
R version 2.12.1 (2010-12-16)
Platform: i386-apple-darwin9.8.0/i386 (32-bit)

[1] es_ES.UTF-8/es_ES.UTF-8/C/C/es_ES.UTF-8/es_ES.UTF-8

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base

other attached packages:
[1] sp_0.9-76

loaded via a namespace (and not attached):
[1] grid_2.12.1     lattice_0.19-13 tools_2.12.1

Note that rgdal.so is where it should be:

imac-de-agustin-lobo:~ agustinlobo$ ls -l
total 15088
-rwxr-xr-x  1 agustinlobo  admin  7722168  4 dic 15:57 rgdal.so

This error is not solved by setting the GDAL path.


More information about the R-sig-Geo mailing list