[R-SIG-Finance] RBloomberg Package Problem

Ana Nelson nelson.ana at gmail.com
Fri Mar 5 23:41:28 CET 2010

There is currently no version of RDCOMClient for R 2.10, and RBloomberg depends on this package.

You can install RBloomberg on R 2.9 with:

This issue will be resolved very soon by switching to the new Java API which will remove the RDCOMClient dependency altogether. Will be announced on this list when available.

----- Original Message -----
From: "Cedrick Johnson" <cedrick at cedrickjohnson.com>
To: "JOSH CHIEN" <joshchien at yahoo.com>, "R-Finance" <r-sig-finance at stat.math.ethz.ch>
Sent: Wednesday, 3 March, 2010 00:32:07 GMT +00:00 GMT Britain, Ireland, Portugal
Subject: Re: [R-SIG-Finance] RBloomberg Package Problem

Try a google search for the package, I ran into the same issue
installing on my new workstation yesterday.


On 3/2/10, JOSH CHIEN <joshchien at yahoo.com> wrote:
> Hi R
> users,
> I’m using
> R on company’s computer, Bloomberg terminal.
> Here
> below is warning message as I have installed Rbloomberg and then to call
> Rbloomberg library.
> But, it
> seems not to work. How to solve for this problem ?
> thanks a lot.
> library(RBloomberg)
> Loading required
> package: RDCOMClient
> : package
> 'RDCOMClient' could not be loaded
> : Warning
> message:
> In library(pkg,
> character.only = TRUE, logical.return = TRUE, lib.loc = lib.loc)
> :
>   there is no package
> called 'RDCOMClient'
> 	[[alternative HTML version deleted]]

Sent from my mobile device

R-SIG-Finance at stat.math.ethz.ch mailing list
-- Subscriber-posting only. If you want to post, subscribe first.
-- Also note that this is not the r-help list where general R questions should go.

More information about the R-SIG-Finance mailing list