[R-sig-Debian] Configure error: checking if libcurl supports https... no --- SOLVED

Rolf Turner r@turner @end|ng |rom @uck|@nd@@c@nz
Tue Aug 31 23:14:06 CEST 2021

On Tue, 31 Aug 2021 12:10:16 +0200
Ivan Krylov <krylov.r00t using gmail.com> wrote:

> Hello Rolf,
> Thanks for the config.log! I think we do have a path forward, but
> there might be some more problems on the way.
> Here's the relevant part of config.log:
> http://paste.debian.net/hidden/a0821b3c
> This system is in a tricky state. There's libcurl and maybe some other
> software in /usr/local. The libcurl installation in particular is
> broken and prevents R's ./configure from linking to system libcurl.
> (I think that the linker ends up trying to link to the static library
> but isn't passed the flags to link curl's dependencies too.)
> Here are some options, maybe one of them would work:
> 1. Run:
>    ./configure \
>     CPPFLAGS="-isystem /usr/include" \
>     LDFLAGS="-L/usr/lib -L/usr/lib/$(uname -m)-linux-gnu"
>    instead of ./configure.
>    Since both the ./configure script and the compiler default to
>    searching /usr/local for headers and libraries to link to, pass
> them flags to make sure that /usr and not /usr/local is searched
> first. 
> 2. Move anything that seems related to libcurl away from /usr/local.
>    This may break some other manually installed software that was
> built with libcurl that had been installed into /usr/local, but
> should not break the system.

Thank you Ivan!!!  You have gone above and beyond the call of duty on
my behalf.  I am extremely grateful.

And thanks to everone else who contributed.

I implemented the number 2 strategy that you (Ivan) suggested and it
worked. Explicitly I did:

sudo apt-get purge curl
cd /usr/local
sudo mkdir Junk
sudo mkdir Junk/include
sudo mkdir Junk/lib
sudo mkdir Junk/bin
sudo mkdir Junk/lib/pkgconfig
sudo mv include/curl Junk/include
sudo mv lib/*curl* Junk/lib
sudo mv bin/*curl* Junk/bin
sudo mv lib/pkgconfig/libcurl.pc Junk/lib/pkgconfig/
sudo apt-get install curl

I then tried the configure step again, and THIS TIME awaaaaaayyyy
it went.  The make step went fine too.

Thanks again.



P.S. Apropos of nothing, really, but it mystifies me how the system got
into the "tricky state" that it was in.  I'm pretty sure that I *never*
installed/tried to install curl "manually".  I am a fervent devotee of
the "sudo apt-get install" paradigm, as long as it works, and it works
with curl. There is no trace of a manual install of curl on my system.

One other thing:  I was exhorted to do an uninstall of the
manually installed version.  Since no trace of any manual install
existed, I could not do this.  Then I thought (just now, after the
problem was solved anyway!) why not create such a "trace"?  So (after a
brief web search) I did:

mkdir curlStuff
cd curlStuff
wget https://curl.haxx.se/download/curl-7.52.1.tar.gz
tar xvf curl-7.52.1.tar.gz
grep uninstall Makefile

Got lots of output, with which I will not bore you.  So it kind of
looks like "make uninstall" *might* have worked.  No way to tell for
sure now, but.  Don't want to mess things up again!


Honorary Research Fellow
Department of Statistics
University of Auckland
Phone: +64-9-373-7599 ext. 88276

More information about the R-SIG-Debian mailing list