[R-sig-Debian] installing R-devel on ubuntu

Mark Leeds markleeds2 at gmail.com
Fri Nov 11 13:26:56 CET 2016

Hi All: I've been trying to install R-devel on my ubuntu 14.04 machine by
following the directions at this link.


The link is extremely clear and detailed but I run into an odd problem. When
I run the script at the bottom of this ( which I call build-R-devel ),  the
following directory structure gets created.

:/usr/local/lib/R> dir
total 56
drwxr-xr-x  4 root root  4096 Nov 11 05:30 doc/
drwxr-xr-x  2 root root  4096 Nov 11 05:30 etc/
drwxr-xr-x 11 root root  4096 Nov 11 05:30 share/
drwxr-xr-x  3 root root  4096 Nov 11 05:30 include/
drwxr-xr-x  3 root root  4096 Nov 11 05:30 bin/
drwxr-xr-x  2 root root  4096 Nov 11 05:30 lib/
drwxr-xr-x  2 root root  4096 Nov 11 05:30 modules/
drwxr-xr-x 32 root root  4096 Nov 11 05:30 library/
-rw-r--r--  1 root root    46 Nov 11 05:30 SVN-REVISION
-rw-r--r--  1 root root 18011 Nov 11 05:30 COPYING

Yet, the --prefix in the configure command says to create
directory.  This causes problems because it ends up looking like I want the
R-devel version to be my regular R version. so when I type

bash R-devel.sh CMD check --as-cran package_xxx.tar.gz that uses
the development version of R>

but, if I type R CMD check --as-cran package_xxx.tar.gz, that also
uses the development version of R.

I essentially lose my ability to access the regular version of R
even though it is sitting in /usr/lib/R.

I think it has to do with the build-R-devel script installing
rather than /usr/local/lib/R-devel but I don't know why it does
that. In the script, the configure command uses
--prefix which is R-devel but I'm not so experienced with these
things so it could be something obvious, I hope ???
I don't know how to debug such a long process with tons of output ?

I've spent about 2 days on this, deleting the resulting directories from the
build of R-devel and trying over and over again  so any insights are REALLY,
REALLY appreciated. Thanks a lot.


my build-r-devel.sh file

## ~/bin/build-R-devel


cd ~/research/svn/R-devel-build

R_BATCHSAVE="--no-save --no-restore"
CC="ccache gcc"
CFLAGS="-ggdb -pipe -std=gnu99 -Wall -pedantic"
CXX="ccache g++"
CXXFLAGS="-ggdb -pipe -Wall -pedantic"
FC="ccache gfortran"
F77="ccache gfortran"
MAKE="make -j4"

#CC="clang -O3"
#CXX="clang++ -03"

#make svnonly

echo "*** Done -- now run 'make install'"

make install

echo "*** All Done -- start R-devel with 'bash R-devel'"

	[[alternative HTML version deleted]]

More information about the R-SIG-Debian mailing list