[R-sig-Debian] Segfaults on Ubuntu 14.04

Dirk Eddelbuettel edd at debian.org
Tue Apr 22 23:21:11 CEST 2014

On 22 April 2014 at 13:55, Carl Boettiger wrote:
| I've just upgraded my Ubuntu system to 14.04 / Trusty Tahr. I now find that
| when I launch the "R" software environment, I immediately get a
| segmentation fault with no further warning or error message.
| I tried removing the relevant base package, which seemed to successfully
| remove R entirely from my system:
|     sudo aptitude remove --purge r-base-core
| I then simply reinstalled r-base-core, but same error persists.


I upgraded a few (older, less used) machines at home on the weekend, and had
no issues.  But I didn't try R. 
| my sources.list shows:
|     deb http://cran.rstudio.com/bin/linux/ubuntu trusty/
|     deb-src http://cran.rstudio.com/bin/linux/ubuntu trusty/

That seems right.  Maybe Michael can chime in. 
| I then simply downloaded the Debian wheezy .deb for R 3.1.0 instead and
| installed that, which worked just fine.  Just wondering if anyone else has

That is potentially not the right thing as Debian can have different library

| encountered this problem on the Ubuntu version and/or if I should report
| this as a bug, and to whom.  (My apologies, the Debian package information
| for the ubuntu .deb file isn't particularly clear on to whom I should
| report bugs).

Here is good. I read it, Michael reads it, ...


Dirk Eddelbuettel | edd at debian.org | http://dirk.eddelbuettel.com

More information about the R-SIG-Debian mailing list