[R-sig-Debian] Ubuntu 13.10 - not able to upgrade R

claude krzisch krzisch.claude at orange.fr
Sun Apr 20 23:50:11 CEST 2014

I work with Ubuntu (now trusty) and I have a problem related, I presume, 
to the upgrade of R : I am unable to download some packages I relied 
heavily on previously as "date","survival" ... I tried to upgrade my 
packages without any success always with the same message : the package 
has been compiled before R 3.0.3, please recompile it. It is the first 
time that I have this type of problem and I don't know how to respond to 
it. Must I download the source package and compile it ? And how may I do 
it ?

Thank you for your help


Le 18/04/2014 21:54, Dirk Eddelbuettel a écrit :
> On 18 April 2014 at 16:39, Martin Bel wrote:
> | I've tried a few different mirrors before, including the rstudio one.
> | To be sure i've tried again with the one you provided, but didn't work.
> We can't really help you at the granularity of "didn't work": What did you
> try?  How did it fail? What were the errors?
> Maybe read some of the HOWTOs on the web about 'how to ask a good question'
> as eg this classic variant: http://www.catb.org/esr/faqs/smart-questions.html
> | I've found this other method, that worked. I guess it's not the official one,
> | right?
> |
> |
> | sudo add-apt-repository ppa:marutter/rrutter
> Yes that is a different repository from the CRAN repository. They are related though.
> I honestly do not know what your question is.  Thousands of people _use_ the
> CRAN Ubuntu repo happily.  Maybe you just need to re-read the README...
> Good luck,  Dirk

More information about the R-SIG-Debian mailing list