[R-sig-Debian] downgrading to R 2.15.1-4 from sid beta 3.0.0
Sebastian P. Luque
spluque at gmail.com
Mon Apr 1 21:12:06 CEST 2013
On Mon, 25 Mar 2013 18:51:24 -0500,
Dirk Eddelbuettel <edd at debian.org> wrote:
> On 26 March 2013 at 07:35, Charles Plessy wrote:
>> Le Mon, Mar 25, 2013 at 03:14:11PM -0500, Sebastian P. Luque a écrit
>> : > On Mon, 25 Mar 2013 13:14:15 -0500,
>> > Dirk Eddelbuettel <edd at debian.org> wrote:
>> > > c) If you must downgrade, I would downgrade to 2.15.3-2 from CRAN
>> > > rather than 2.15.1.
>> > Great, doing that right now.
>> Hi Sebastian and everybody,
>> Note (if it helps) that it is also available from
> Ace -- thanks for the reminder about snapshot.d.o.
> As for Seb's query about mass-updates: what you do from ESS, I do from
> shell via littler -- and yes, I usually control via lib.loc(). In this
> case we may want to force it everywhere... though I can't fully
> recommend to overwrite files owned by dpkg and apt-*. If it breaks,
> you keep the pieces.
> And lastly, this is of course a bug in r-base as it could potentially
> conflict with its dependents. In practive, I don't see how we could do
> this easily so the best bet is probably to simply upgrade the .deb
> packages as fast as possible.
> My ~/bin/update.r is below, with some comments removed. A version is
> also in the littler sources and Debian package.
Thanks Dirk and Charles for the pointers. I'm now running a locally
installed R 2.15.3 and packages until the dust settles with 3.0.0.
I just noticed that many sid packages have now been rebuilt against R
3.0.0. Kudos to Dirk and the team! However, I don't understand how
this works for packages that have an upstream Depends on R < 3.0.0. One
of these is nlme, and yet r-cran-nlme has been rebuilt against R 3.0.0,
even though it fails to load in this latest R with:
Error: package ‘nlme’ was built before R 3.0.0: please re-install it
What am I missing?
More information about the R-SIG-Debian