[R-sig-Debian] R 2.11.0 for Ubuntu 10.04 Lucid Lynx on CRAN

Mauricio Zambrano hzambran.newsgroups at gmail.com
Mon Jun 7 18:36:17 CEST 2010

2010/6/7 Michael Rutter <mar36 at psu.edu>:
> On 06/07/2010 10:56 AM, Mauricio Zambrano wrote:
>> Thanks Michael for your answer.
>> The problem is just there: when I use the sudo account, I got the
>> following error message:
>>     update.packages()
>> --- Please select a CRAN mirror for use in this session ---
>> Loading Tcl/Tk interface ... done
>> Warning: unable to access index for repository
>> http://cran.rakanu.com/src/contrib
>> Warning message:
>> In open.connection(con, "r") :
>>   unable to connect to 'cran.r-project.org' on port 80.
>> But when I use my normal user account (within the same terminal form
>> which I run sudo), I can update the packages, but creating a new
>> version of the packages library within my user account.
>> So I think the problem is not the Internet/proxy configuration of my
>> PC, but something else that it is very strange for me.
>> Thanks in advance,
>> Mauricio
> Mauricio,
> You may have an error in sudoers file, which configures how the sudo command
> can be used.  This would be an Ubuntu issue, and more information can be
> found here: https://help.ubuntu.com/community/Sudoers.
> You may also want to try:
> update.packages(repos="http://lib.stat.cmu.edu/R/CRAN")

I tried with this and it doesn't work.

> This will bypass the need to get a list of mirrors.  You could also try your
> local cran mirror.  If this fails, you have an issue accessing the internet
> via sudo in Ubuntu and you would need to figure out why.

After some verifications, I confirmed that the problem is in my
internet connection via sudo with some applications and not in the
upgraded version of Ubuntu 10.4 with R 2.9.11, and I'll try to figure
out why.

(what is strange is that 'sudo apt-get update' works fine from the
console but 'update.packages()' doesn't within a sudo session...)

> Hope this helps,
> Michael
> --
> Dr. Michael A. Rutter
> School of Science
> Penn State Erie, The Behrend College
> Station Road
> Erie, PA 16563
> http://math.bd.psu.edu/faculty/rutter

Thank you very much for your valuable help.

Kind regards,


Linux user #454569 -- Ubuntu user #17469
Dept. of Civil and Env. Engineering
University of Trento, Italy

More information about the R-SIG-Debian mailing list