[R-sig-Debian] R 2.11.0 for Ubuntu 10.04 Lucid Lynx on CRAN

Mauricio Zambrano hzambran.newsgroups at gmail.com
Mon Jun 7 15:26:30 CEST 2010

Dear Michael,

I'm sorry for getting your attention back to this issue again, but
after a week I'm still not able to update my R packages (with root
privileges)  after upgrading to Ubuntu 10.4 from Ubuntu 9.10 (trying
with several mirrors):

Error: could not find function "upddate.packages"
> update.packages()
--- Please select a CRAN mirror for use in this session ---
Loading Tcl/Tk interface ... done
Warning: unable to access index for repository
Warning message:
In open.connection(con, "r") :
  unable to connect to 'cran.r-project.org' on port 80.

However,  today I tried (as last resource) to update the packages by
using my normal user account, and that worked immediately (very
strange for me, because I used the same terminal for both operations).
The problem is that before upgrading the packages, R ask me if I want
to create a new personal library, situation that I would like to avoid
since I have all the packages installed in the
'"/usr/local/lib/R/site-library' directory.

Warning in install.packages(update[instlib == l, "Package"], l,
contriburl = contriburl,  :
  'lib = "/usr/local/lib/R/site-library"' is not writable
Would you like to create a personal library

After searching on the web it seems that I'm the only user with this
problem, and I would really appreciate if you could give me any hint
about how to solve this problem, that seems more related to Ubuntu
than R.

Thanks in advance for any help.


Linux user #454569 -- Ubuntu user #17469
Dept. of Civil and Env. Engineering
University of Trento, Italy

2010/6/1 Michael Rutter <mar36 at psu.edu>:
> On 06/01/2010 07:05 AM, Carlos J. Gil Bellosta wrote:
>> Hello,
>> What runs underneath is the download.file() function.
>> Can you download a file with it? For instance, I can do
>> download.file( "http://www.google.com/index.html", "index.html" )
>> Can you?
>> Best regards,
>> Carlos J. Gil Bellosta
>> http://www.datanalytics.com
>> 2010/6/1 Mauricio Zambrano<hzambran.newsgroups at gmail.com>:
>>> 2010/6/1 Carlos J. Gil Bellosta<cgb at datanalytics.com>:
>>>> Hello,
>>>> Did you try an alternative CRAN mirror?
>>> Yes, I have tried some of Spain, UK and Italy, but I still get the
>>> same error message....
>>> Kinds
>>> Mauricio
>> _______________________________________________
>> R-SIG-Debian mailing list
>> R-SIG-Debian at r-project.org
>> https://stat.ethz.ch/mailman/listinfo/r-sig-debian
> Mauricio,
> I was successfully able to use 'update.packages' using mirrors in both Spain
> and the UK, so I can't replicate the problem right now.  I do recall having
> a similar issue a couple of weeks ago, but the problem fixed itself within a
> couple of hours.  I just assumed that the mirror I was using was having some
> downtime.
> Are you updating packages under your username or sudo?  I think Carlos is on
> the correct track in that the account or session you are using doesn't have
> access to the internet for some reason.  Have you rebooted your machine
> lately?  That may fix a problem another update created.
> Hope this helps,
> Michael
> --
> Dr. Michael A. Rutter
> School of Science
> Penn State Erie, The Behrend College
> Station Road
> Erie, PA 16563
> http://math.bd.psu.edu/faculty/rutter

More information about the R-SIG-Debian mailing list